Need help with my newly installed Ubuntu 12.04 system (dual booting along with Win 7), even thoguh I can use internet using the modem and directly plugging it, the wireless network is disabled and it says firmware missing.

I tried the following options:

  1. Checking to see if the wireless is disabled using the hot keys (F2 or Ctrl+F2 , Fn+F2 keys), the wireless is working fine in Win 7 but not in Ubuntu.

  2. I am able directly plug the laptop with the modem and able connect to Internet using Ubuntu.

  3. From the top right hand menu bar, te Wireless networks options say "device not ready (firmware missing) and the Enable Wireless checkbox is checked.

  4. tried the command rfkill list , it shows all are NOT blocked.

    0: phy0: Wireless LAN soft blocked:no Hard blocked: no

    1: dell-wifi: Wireless LAN soft blocked:no Hard blocked: no

    2: dell-bluetooth: BlueTooth soft blocked:no Hard blocked: no

    3: hci0 Bluetooth soft blocked:no Hard blocked: no

  5. ifconfig command shows eth0 and lo (lcoalhost) up and running but the wlan0 option is not available to show unless I type ifconfig -a, when it shows wlan0 but its down.

  6. The command lspci -vvnn | grep 14e4 shows

    04:00.0 network Controller [0280]: Broadcom Corp BCM4312 802.11b/g LP-PHY [14e4:4315] {rev 01) 08:00.0 Ethernet Controller [0200]: Broadcom Corp Netlink BCM5784M Gigabit Ethernet PCIe [1434:1698] {rev 10)

  7. The file /var/lib/NetworkManager/NetworkManager.state shows all options are true (networking enabled, wireless enabled, wwlanenabled and wimaxenabled all options are set to true).

8) 'additional drivers' in your Dash and/or Preferences do not bring up anything at all.

9) output for lshw -C network shows

*-network DISABLED
description : Wireless interface
physical id: 4
logical name: wlan0
serial: 78:e4_00"43:b6:ab
capabilities: ethernet physical wireless
Configuration: broadcast=yes driver=b43 driverversion= firmware=N/A link=no multicast= yes wireless=IEEE 802.11bg

never Mind, i was able to figure it out, I actually installed b43-fwcutter driver manually by coying the file from a network earlier but i guess that was not the correct way.

Solution: I connected directly using the modem and network cable and used System Settings -- > Additional Drivers and have it download the **Broadcom STA Wireless Driver automatically from the internet and activate it and restarted my laptop. Wireless now works as expected.

FYI: In case : you are not able to use my solution (i.e. not able to connect to internet and download the driver automatically) , i found this while searching for all these issues in help pages which might be useful to you.


Happy Surfing!

  • Glad you got it working! – fleamour Sep 23 '12 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.