I have three operating systems on my machine, Windows 7x64, Ubuntu 11.10 and 12.04 both x64 as well. All three were running at full resolution for my monitor, as well as in the Grub 1.99 boot screen.

After booting into Windows, I rebooted my machine and found my Grub resolution was suddenly 640x480. Booting into both versions of Ubuntu, I find myself stuck at that resolution as well.

I made no driver changes recently, and hadn't even booted into the 11.10 build in a month or more. I've gone through both proprietary Nvidia driver options for my card (GeForce 9800GT) as well as the open source drivers in 12.04 to no avail.

I can't figure out what could have caused this change in both versions of Ubuntu and Grub simultaneously. Windows 7 is unaffected so I think that safely rules out hardware failure.

EDIT Ok, so I couldn't boot an graphical live disks, I tried ubuntu 12.04 i386 and x64 as well as 12.10 beta x64 and all of them would flash the initial logo, go to a blank screen with a flashing cursor in the upper left and then my display would die. I managed to boot 12.04 server and get into recovery. I reinstalled grub and went into recovery mode for my 12.04 build. If I boot in safe graphics mode I can get 1280x768, but as soon as I reboot it's broken again. I've tried reinstalling the nvidia drivers and that leaves me with a system stuck at max 640x480. None of these changes have had any impact on the 11.10 build, which is still stuck at 640x480 Given that I can push a somewhat higher resolution in 12.04, and full resolution in windows 7 I'm pretty convinced it's not an issue of my monitor failing. It must be something to do with the graphics drivers. I can't figure out what could be the issue though. I'm especially perplexed that I can't boot any live images

  • Does it happen only in Grub or in Ubuntu as well? – Anwar Sep 15 '12 at 17:09
  • Sorry if I wasn't clear, the resolution is in grub AND in both builds of Ubuntu. Actually, since I posted this, the problem has degenerated. I can still boot into 11.10 (at 640x480) but now it freezes booting into 12.04 altogether. I've created a boot USB of 12.10 and 12.04 and it won't load either of them either, it flashes the initial logo and then my display goes inactive. Really confusing and frustrating – iPreston Sep 15 '12 at 22:20
  • Grub2 and Ubuntu uses the monitor EDID each time to set the resolution. If the monitor is failing in this regard it can cause resolution problems. Try removing the monitor plug from the computer, check the pins, then make sure it is seated properly in the socket and screwed in. Repeat for the socket on the monitor if it has one. The nature of the problem seems to indicate hardware as a cause (resolution was working, now it's not and it's deteriating). You could try a different monitor and see if the problem changes. – fabricator4 Sep 15 '12 at 23:27
  • I'd agree with the diagnosis, except it's not deteriorating in 11.10, just in 12.04 and it's still functioning perfectly in Windows 7. I'll see if I can get my hands on another monitor to test this out though – iPreston Sep 16 '12 at 7:40

This fixed it for me. The issue was with ubuntu not liking the EDID information it got from my monitor. Apparently windows just ignores that stuff, which is why it worked there.


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.