I am looking for ways to debug (or understand why things don't work as I expect with) the initialisation of an SCSI-2 device (Microtek ArtixScan 4000t) using a PCMCIA adaptor (Adaptec SlimSCSI 1450B) on my old P4 Laptop with Ubuntu 9.10.

I use vuescan as it is capable of recognising the 4000t - and the author of vuescan assures me that it should work.

On insertion in my Ubuntu system, the PCMCIA-SCSI adaptor shows as Socket 0 Device 0: [aha152x_cs] (bus ID: 0.0) (lspcmcia) and resets the scanner, but vuescan does not detect the scanner and no device shows with lsscsi or lspci. I tried as root just in case, same story.

I have also tried without success on a Windows XP laptop. Same as above, the adaptor is recognised by the system and the scanner gets reset on insertion of the PCMCIA card, but vuescan does not see the scanner.

Back to Ubuntu, I tried the command echo "scsi add-single-device 0 0 ? 0" > /proc/scsi/scsi with 0 and 2 for ? (having set the scsi device number on the scanner to 0 or 2) to no avail. with 2 it said the parameter was incorrect, with 0 it accepted but did not seem to do anything with it. /proc/scsi/scsi is always size 0. I have tried those commands as root, and tried starting vuescan both under my regular user and as root. In every try so far with the 4000t (and Adaptec SlimSCSI 1450B PCMCIA-SCSI adaptor) vuescan does not see any scanner.

I would appreciate any lead that would help me debug or fix this issue.

  • Hello, this question has no information and activity for a very long time. I am closing it for now. If by any reason you think this question is still viable or useful in anyway or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reason(s) why you want it open. Regards
    – fossfreedom
    Feb 21, 2012 at 21:50


Browse other questions tagged .