How can I use a usb stick in the virtual machine ? When I opened 'settings', a warning opened by itself and said that I had to add my user to the group vboxusers. I did that (sudo adduser naomi vboxusers), but the warning is still displayed, and the usb stick is still not recognized by the VM, although it is by the host. If I click 'add' on the 'usb' tab of the settings, it says 'no device available'.



seems you have the wrong command, the correct one is in the VirtualBox Documentation

sudo usermod -a -G vboxusers username

(Where username is the user you want to add)

There you go, after you do that all you need to do is open Vbox and select Devices > USB > "Whatever usb device you want to add"

  • Okay, how can I undo the command I used then? – NaomiJO Sep 14 '12 at 16:06
  • Well in either case I tried this command too, and usb still doesn't work. – NaomiJO Sep 14 '12 at 17:29
  • 1
    Have you installed the "Oracle VM Virtualbox extension pack" in the correct version? It should work (at least works for me). Is the group vboxusers displayed when you type groups in a terminal? You have to logout and back in after adding a group btw. – Axel Sep 14 '12 at 17:37
  • Yes sorry, I hadn't logged out yet. – NaomiJO Sep 14 '12 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.