I want to buy a Dell Inspiron 15R Special Edition. On ubuntu.com, it says that Dell Inspiron 15R will work properly. But the special edition has some special issues.

I will list the hardware:

  • 3rd Generation Intel® Core™ i7-3612QM processor (6M Cache, up to 3.1 GHz)
  • 15.6" Full High Definition (1080p) LED Display
  • 8GB2 Dual Channel DDR3 SDRAM at 1600MHz
  • 750GB 7200 RPM SATA Hard Drive
  • 8X Tray Load CD/DVD Burner (Dual Layer DVD+/-R Drive)
  • AMD Radeon™ HD 7730M 2GB
  • Built-in Skullcandy™ stereo speakers and Waves MaxxAudio® 4 technology

Will it have any problem?

  • I have a Dell Inspiron 17R (5720) and the touchpad doesn't scroll and external mouse doesn't work in Ubuntu 12.10.
    – alfC
    Oct 19, 2012 at 13:23
  • Correction: should say wireless external mouse (Logitech Anywhere)
    – alfC
    Oct 19, 2012 at 17:23
  • Scrolling works for me with a patch. See this bug report: bugs.launchpad.net/ubuntu/+source/linux/+bug/606238 Dec 23, 2012 at 21:00
  • In addition to the answer by @Dave B, I would suggest getting the new 13.04 Ubuntu release (64-bit version which is recommended by Canonical for modern UEFI computers). It worked better with me on a Dell XPS 8500 SE (with SSD caching drive).
    – Ahmadgeo
    May 10, 2013 at 15:52

3 Answers 3


I've just finished installing Kubuntu 12.04.1 LTS on this machine. Notes (unfortunately, I spent about 14 hours getting this to work, so I'm attempting to pull together the various pieces that seemed to work, rather than having a tested final procedure). In short, no, this is not a problem-free installation:

  • If you want to use the SSD as a drive in Linux

    • In windows, search control panel for "Intel", in the Intel Smart Response Technology panel, disable acceleration entirely
    • Note: this is only if you intend to use the SSD as a regular drive in Kubuntu, if you actually use Windows you may wish to keep it enabled as a cache for Windows, but that is untested.
  • WARNING: Do not disable SRT in the bios, or your windows will become unbootable (it will blue-screen)

  • WARNING: Do not resize the Windows 7 partition with regular partition editors, as they will move the partition to incorrect offsets and windows will spend an hour moving them back only to have them junked. I wound up having to delete the windows partition and do a factory restore onto a new (smaller) partition to get Windows to boot

  • you need to enable dmraid in order for the Ubiquity installer to see the hard drive for installation

    • Boot Kubuntu Live CD/USB-Key, choose "Try Kubuntu"

    • Start a console

    • sudo modprobe dm_mod
    • sudo dmraid -ay

    • Install Kubuntu

    • WARNING: a bug in Kubuntu's installer means that it will select /dev/sdb as the default MBR target, you must select /dev/sda

    • WARNING: do not attempt (as suggested in various locations) using "apt-get remove dmraid", as while that allows you to install Kubuntu, it winds up installing the MBR to the wrong location (it does not get used when the controller is in "STR" mode)

  • Switchable AMD Graphics (Intel + AMD)

    • Intel graphics work fine out-of-the-box

    • To enable AMD graphics you need at least the AMD fglrx 12.9 beta, as the switchable graphics don't work on the stable releases. Directly downloaded from AMD, do not use the install-fglrx-debian.sh script, as it installs a slightly older copy that does not recognize the card in the machine. Use the "build a deb" option in the installer. Run the aticonfig --initial script, reboot to pick up the new driver, run amdcccle to confirm that it worked.

    • Note: performance of the AMD graphics does not appear particularly good, glxgears shows 800fps or so, so there may be no actual advantage to installing the support package

  • Sensors/hardware

    • install lm-sensors, run sensors-detect, allow it to add coretemp to the boot modules (to get some temperature monitoring)

    • There is no fan-speed control, so expect your fans to run continuously (and they are noisy)

  • I do not see 802.11/n access points, though the driver claims to be 802.11/n capable

Everything else seems to work so far:

  • webcam
  • HDMI Video output
  • regular wifi (b/g)
  • keyboard and trackpad
  • bluetooth
  • speed-step (cpu frequency scaling)
  • basic suspend on lid-close/resume on open, but with a scary-looking "failed to resume" message before it comes back up, likely due to some hardware not resuming properly


  • SSD
  • Hardline networking
  • Card reader
  • HDMI Audio Output
  • Does the scrolling of touchpad works for you?
    – alfC
    Oct 19, 2012 at 17:26

I believe I have exactly this laptop with Ubuntu 12.04 running smoothly. Granted, I haven't checked every single piece of hardware for functionality but display, wireless, sound, USB and Bluetooth appear to work as expected.

A couple of useful tidbits I discovered while playing around over the past few days:

  1. If you want Unity 3D desktop features to work properly, do not install the proprietary drivers for your graphics card. When I did this, Unity 3D stopped working and I could not identify a simple workaround. After deactivating the proprietary drivers, I went one step further and did a clean install of the open source Raedon drivers, following: How to install Radeon Open Source Driver? and Unity 3D works fine.

  2. You'll probably notice that the fan runs at high speed at all times. I found several websites explaining how to use the "i8kutils" packages to manage fan speed, and the solution appears to work well. For example: http://ubuntuforums.org/showthread.php?t=842775 Load the module was required for the fan settings to take effect: sudo modprobe i8k.

My configuration file (/etc/i8kmon.conf) looks like:

# Run as daemon, override with --daemon option
set config(daemon) 1

# Automatic fan control, override with --auto option
set config(auto) 1

# Status check timeout (seconds), override with --timeout option  
set config(timeout) 2

# Report status on stdout, override with --verbose option
set config(verbose) 1

# Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
set config(0) {{0 0} -1 55 -1 55}
set config(1) {{0 1} 50 60 55 65}
set config(2) {{1 1} 55 80 60 85}
set config(3) {{2 2} 70 128 75 128}

# end of file

I've been keeping an eye on the core temps to make sure that the fan settings are sane, and they appear to be. To this end:

sudo apt-get install lm-sensors
sudo sensors-detect

followed by installation of the Hardware Sensors Indicators,

sudo add-apt-repository ppa:alexmurray/indicator-sensors
sudo apt-get update
sudo apt-get install indicator-sensors

For reference and comparison of hardware, here is the output from lspci:

00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 682f
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)
08:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
  • I confirm Dave B. message. proprietary drivers break unity 3d. i8kutils do works, but there is something that may be important: config file: is /etc/i8kmon.conf or /etc/i8kmon ?? (I created both) Also I inserted "i8kmon --daemon" at startup The Fan is now at 84000 RPM (was more than 150000 before) You can install "Hardware Sensors Indicator" applet to monitor the fan RPM The only strange thing is that the temperature is a bit high (71°C). The day is hot (30° but I think 71C is too high Some say that its because of being a i7 CPU... Feb 16, 2013 at 16:00

I don't use a computer with the specs that you listed but searching for the video card(the only difference between the 15R and 15R special edition that I could find) shows that the AMD 7700M series is certified hardware. I will include the link below, the card is the 9th in the list:

Ubuntu.com certified hardware

The 7700M Series should include your card, everything else is pretty standard and should provide you with no issues. I cannot guarantee that of course but I don't see anything that would be a concern. If you want to check components yourself you can by searching HERE they are listed by type manufacturer and name.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .