My audio is no longer working in Xubuntu 12.04 after working fine for about a year. This happened right after visiting the following website and installing an audio browser application to upload voice samples for the creation of an open-source speech recognition program: http://www.voxforge.org/home/read

I do not know if that is what caused the problem, but audio stopped working around the same time I installed this web application.

When I type in the terminal

pulseaudio -D

I get the following:

E: [pulseaudio] main.c: Daemon startup failed.

I tried the following next:

sudo apt-get purge pulseaudio
sudo apt-get install pulseaudio

When I type 'pulseaudio' at the command prompt, I get:

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.
  • Look in /var/log/syslog for anything related to pulseaudio and dbus. If you find error messages related to that please post some of the most recent ones.
    – Karl Frisk
    Sep 26, 2012 at 16:43
  • Content of syslog for pulseaudio: MACHINE pulseaudio[3801]: [pulseaudio] main.c: Using state directory /home/USER/.pulse. MACHINE pulseaudio[3801]: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-1.1/modules. MACHINE pulseaudio[3801]: [pulseaudio] main.c: Running in system mode: no MACHINE pulseaudio[3801]: [pulseaudio] pid.c: Daemon already running. MACHINE pulseaudio[3810]: [pulseaudio] pid.c: Daemon already running. MACHINE pulseaudio[3810]: [pulseaudio] main.c: pa_pid_file_create() failed.
    – lkamal
    Apr 18, 2014 at 8:53

8 Answers 8


This happened to me too. I think the primary reason is the pulseaudio daemon isn't killed properly.

First run pulseaudio --kill then pulseaudio --start.

This fixed the problem for me.


There are two potential fixes, here are the two methods I tried (I'm not sure which of the two fixed the issue.)

Fix 1

I plugged in some headphones and killed pulseaudio:

pulseaudio --kill

then I started it again:

pulseaudio --start

This seemed to fix the issue from then on.

Fix 2

Using pavucontrol instead:

sudo apt-get install pavucontrol

This is an update for 13.10.

I used pavucontrol:

sudo apt-get install pavucontrol

The steps that solved an identical issue on my Ubuntu 16.04 were:

rm -R ~/.config/pulse   # or rename this folder
sudo systemctl reboot   # logout and login doesn't do the job
  • 2
    Finally something that fixed the issue here, and such a simple solution. Removing ~/.pulse didn't help, but ~/.config/pulse did the trick. Still drives me nuts how high maintenance linux can be sometimes. Bugs seem to appear randomly, and fixing can be a time-consuming painful task. Rant almost over; now I need to tackle my s-l-o-w boot up sequence. :/
    – macflav
    Mar 18, 2018 at 16:41
  • it worked. Thanks.
    – 111
    Feb 2, 2020 at 20:49

This worked for me

sudo /usr/bin/amixer set Master toggle

I tried all the other things suggested in this thread, and nothing worked.


I got the same problem:

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

and removing/installing pulseaudio didn't help. Finally I have found out that my .pulse directory in $HOME was missing. So I did:

cd $HOME
mkdir .pulse
pulseaudio --kill
pulseaudio --start

and restarted my ubuntu. After it was fine.

  • Curiously this worked for me. Maybe my ~/.config/pulse is messed up and it's just using ~/.pulse now instead?
    – xjcl
    Jan 25, 2020 at 0:23

You may try to delete or rename the .pulse directory in your homefolder, logout and relogin.A new .pulse-directory will be created automatically by pulse, so most likely youll get a useful configuration. This has helped me in many times when i got problems with pulse.

  • hmmm.. well I tried renaming the .pulse file and a new .pulse file was indeed created after restarting my system. Unfortunately my computer is still completely silent. Are there any sound drivers to remove and reinstall or anything like that?
    – Ben
    Sep 13, 2012 at 22:03

I fixed my own problem by simply entering "alsamixer" at the commandline and playing with some of the settings such as unmuting various volume controls for different components and that solved the problem. Probably the software at voxforge.org muted some volume controls on my computer and failed to unmute them afterwards. Thanks for the help, everyone!

So, my solution was:


and unmute various volume controls until the sound comes back. Also try switching between soundcards with F6. (It's helpful to have a youtube video playing in the background, or some music on a playlist playing so you know when the sound is finally back.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.