18

Hello can anyone help me, my time on the menu bar has disappeared, one day I noticed it was gone, in system settings I do not have a time and date option either.

I am running Ubuntu 12.04, please help

  • 7
    try initctl restart indicator-datetime,it will help restart the datetime indicator service. – hajimuz Jun 22 '14 at 13:05
  • @Momo mind turning this into an answer? This was the solution I ended up using and it worked fine. Ubuntu 14.10. – Joe Apr 2 '15 at 13:56
37

For me, this make the clock, time, date come back to menu bar: killall unity-panel-service

| improve this answer | |
  • 3
    I have tried that in ubuntu 14.04 and it works too. – cytsunny Feb 16 '16 at 17:46
4

I just had this problem while I was also dealing with another bug to do with my keyboard layout changing spontaneously, and the fix for that also brought back my time and date display.

Try the following command:

sudo restart lightdm

Seemed to work for me, anyway. Hope this helps.

| improve this answer | |
  • 3
    Note that this will restart your current X session so all of your running programs will be terminated. You'll probably want to close everything you're working on before running this. – Trey Hunner Dec 9 '13 at 18:35
1

You need to add the panel "indicator" for date and time back by running:

sudo apt-get install indicator-datetime

That will restore the time readout on the top panel for you.

| improve this answer | |
1

As someone pointed out, I typed:

initctl restart indicator-datetime

and it worked fine.

| improve this answer | |
0

I suggest that you repair the Unity and check if the issue is resolved. I had the same problem once and the following commands did the trick.

dconf reset -f /org/compiz/
setsid unity
| improve this answer | |
0

It means your chosen region is not matched to your local server.

To correct:

  1. set the time and date to your actual region (e.g. China)

  2. use synaptic to select the repository server for your actual region (e.g. China).

  3. reboot.

This should solve the issue. Recurrence may be caused by change in location, or change in server, or update/upgrade. If so, repeat the above.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.