2

My headset broke recently and now only left side of it works. In some songs, there are parts that are only played through the right side and since my right side doesn't work, I can't hear them. I want to set the sound so it only plays on the left side. I tried changing the balance settings in sound preferences, but it only mutes the right channel, doesn't make it play through the left channel. How can I do this?

  • You should look at making the sound mono. Apparently with stereo music the tracks can super impose and ruin the music. I'm not sure it's so bad but I think that's the track you want to go down. – Joshua Siret Sep 10 '12 at 16:58
  • Hm... I know iOS has this as an accessibility feature, but I don't see it under ubuntu universal access. This should definitely be added! Voice your opinions here bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/… – hnasarat Sep 10 '12 at 17:29
1

I found the solution at ubuntuforums.org, here's the link:

http://ubuntuforums.org/showthread.php?t=1384860&p=8689164

Basically you switch from pulseaudio to alsa, and you enable something called crosstalk, that allows you to hear both channels without 'super imposing' them.

0

Taken from https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/942780

The mono profile is usually thrown away as most hardware does not support opening it in one-channel mode only.

You can configure pulseaudio to do what you suggest by modifying /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf and /usr/share/pulseaudio/alsa-mixer/profile-sets/extra-hdmi.conf

In both files, go to the [Mapping analog-mono] section and change channel-map = mono to channel-map = mono,mono

This will take effect the next time pulseaudio is restarted (e g by rebooting).

The major question is however, whether we should do this by default, and if we risk regressing other hardware by doing so.

-- David Henningsson (diwic)

  • I tried this approach, but I couldn't find an extra-hdmi.conf file (it no longer seems to exist), and when I just modified default.conf as described it broke my sound completely. YMMV. – machineghost Jul 29 '16 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.