I installed with apt-get, checked out the man page and added . /usr/share/autojump/autojump.sh to my .bashrc, like it says. When I cd around the filesystem, nothing gets added to ~/.local/share/autojump. I then tried adding . /usr/share/autojump/autojump.bash, but that didn't work either.

autojump -a ~/Dropbox properly creates a file ~/.local/share/autojump/autojump.txt, but running j Drop < TAB > doesn't autocomplete to j ~/Dropbox/ as it should. However, j < TAB > does autocomplete to j ~/Dropbox.

I know my bash-completion is working since it works for git, dd, and others.

I know there's a newer version in the repositories set for Quantal. Perhaps that would work? I don't know how to install that version though. I've used autojump with mac homebrew (and it installed without any issue), so I know there is missing functionality.

In general I'm really annoyed that I can't get this working...I've spent hours on it! Needless to say, help would be very appreciated.

  • You might want to say how you installed autojump, whether it was via the .deb package. It's not clear if it's installed correctly. – user1614 Sep 9 '12 at 22:14
  • I thought my first sentence made that clear -- I installed with sudo apt-get install autojump. – hnasarat Sep 10 '12 at 0:04

OK, I think I have a handle on how this works.

You'll probably want to add the following to your .bashrc:

source /usr/share/autojump/autojump.bash

This should do what you're expecting it to do.

Also, what does jumpstat bring back?

  • I installed the newest version autojump (v20) from here packages.debian.org/sid/autojump but still nothing is added to the ~/.local/share/autojump/autojump.txt file. I even set $XDG_DATA_HOME to ~/.local/share – hnasarat Sep 10 '12 at 1:22
  • I also tried sourcing the autojump.bash script like you say and it doesn't do anything different. jumpstat only reports directories I've added manually: 1.0: /home/hashem/temp 1.0: /home/hashem/Dropbox/ Total key weight: 2. Number of stored paths: 2 – hnasarat Sep 10 '12 at 1:23

(As posted in https://github.com/joelthelion/autojump/issues/148 )

autojump silently fails if PROMPT_COMMAND has been overwritten:

If in your .bashrc you have export PROMPT_COMMAND="history -a; history -n;"

PROMPT_COMMAND - which autojump requires - will fail to be set properly.

Instead do: export PROMPT_COMMAND=$PROMPT_COMMAND"; history -a; history -n;"

  • Gah, that sounds like a bug for the original author. – user1614 Sep 10 '12 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.