Specs: Intel Core i7 Win7 32-bit nVidia GeForce GTX 560 23 inch monitor

I have an Ubuntu DVD. It boots fine, but when I select any of the options (like "Install Ubuntu") I get a blinking cursor which blinks forever.

The DVD also works fine on other PCs, even having lesser specs like Pentium D.

DVD name: ubuntu-12.04.1-dvd-amd64.iso

Is it the problem of my nVidia Graphics card?


One solution that comes straight to mind is that you are using a 64bit DVD but have a 32bit W7 installed. The W7 installation won't make a difference but maybe your processor is 32bit.

Download the 32bit DVD and try installing again.

I don't think the GFX card will be causing the problem, nVidia and Intel are usually the best options for Ubuntu.

Good luck!

  • If the processor was 32 bit, the disk would not load at all. If he's got this far then it must be something else. – Sman789 Sep 9 '12 at 20:54
  • Thanks captain_G... But my processor(Core i7 2700k) is surely 64-bit capable... – Sam Sep 10 '12 at 11:52

The problem is unlikely to be your nVidia card - they are quite well supported and its unlikely that a problem with it would manifest itself in this exact way anyway.

I've had problems with Live CDs before, and I would recommend firstly trying the CD again if you haven't already.

If it still doesn't work, consider using a live USB instead. I've found them more reliable personally. The Ubuntu website has great instructions for creating them, and you will also find that the installation goes much more quickly if it does end up working.


If you don't have a USB stick, or really don't want to use one, try burning a different CD. Sometimes CDs don't burn properly and errors can result, so getting a different one and trying again might help.

Whilst there's a chance that the problem is with Ubuntu, and we will of course help you if they are, it's probably a good idea to eliminate these disk-related possibilities first as they are much more likely to be the cause.

  • Thanks! I just tried bootable usb stick and it behaves the same way as disk... I also tried burning other disk....with no success Both disks work fine on my other PC(with no gfx card) – Sam Sep 10 '12 at 11:50


Yes the graphics card was the problem!

I just answered a similar question here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.