16

My synaptic package manager is not launching from the application menu but i can launch it from terminal with gksudo synaptic. I have tried several times but I can't launch it from the application menu.

The Launch command is synaptic-pkexec (this is accessed from the application menu editor).

  • There is not enough information in your question. Can you post the contents from synaptic launcher. It is located in /usr/share/applications. It is either synaptic-pkexec.desktop or synaptic.desktop (Not using Ubuntu now, so I cannot check) – Aleksandar Sep 9 '12 at 9:29
  • @Aleksandar Thanks for responding , i am not getting what you are saying .could you explain more ? – rɑːdʒɑ Sep 9 '12 at 9:31
  • Go to "Main menu" and see what the synaptic launcher command is. – To Do Sep 9 '12 at 9:33
  • @August, do what ToDo said. – Aleksandar Sep 9 '12 at 9:48
  • Yes, goto Main Menu and see what has changed in Synaptic Menu. – Naveen Sep 9 '12 at 12:28
17

You can fix it by following:

  1. Open terminal (ctrl+alt+T) and execute:

    gksudo gedit /usr/share/applications/synaptic.desktop
    

    If gksudo is not installed, you can just install it. It's provided by the gksu Install gksu package.

    (Or you can run sudo -H gedit instead. But avoid sudo gedit).

  2. Change line Exec=synaptic-pkexec to Exec=gksudo synaptic.

  3. Save file and close text editor.

| improve this answer | |
  • It will allow you to easily launch synaptic, but wont remove bug. If you want to remove bug run pkexec --user root nautilus(in gnome). It should ask you for password and run file manager (nautilus) as root - write here, if it wont work. – kubahaha Sep 10 '12 at 16:52
  • hi +1 , but actually i did an aswer by mixing both of you guys i mean Naveen , To Do and yours . I have opened terminal and typed as alacarte and found synaptic , in its properties i have replaced that command with gksudo synaptic and that did the trick . Thank you both of you . – rɑːdʒɑ Sep 10 '12 at 18:46
  • 1
    @kubahaha I have exactly the same problem, synaptic-pkexec does not start. It asks for authentication and does nothing later. pkexec -- user root nautilus produces the same behaviour. The error is: No protocol specified ** (nautilus:3040): WARNING **: Could not open X display (nautilus:3040): Gtk-WARNING **: cannot open display: What could be wrong? – deshmukh Sep 4 '13 at 9:57
  • Use a policy kit askubuntu.com/a/450559/159431 – iyrin Apr 19 '15 at 18:53
  • it open to me a new document to edit. totally empty. I cannot do step 2. any tip ? – McLan Oct 27 '15 at 11:45
0

I encountered the same problem, while I was trying to set up a new IBus input method for my newly installed Lubuntu 12.04.

I resolved the problem by purging and re-installing the IBus package:

sudo apt-get remove --purge ibus
sudo apt-get install ibus

My Synaptic Package Manager now launches again, its application shortcut 'synaptic-pkexec' remains unchanged.

| improve this answer | |
  • 1
    I don't see what the ibus package have to do with Synaptic. – Braiam Aug 25 '13 at 14:37
  • It worked for me also, but removed ubuntu-desktop, Rhythmbox etc. So I have to install it one by one. – learner Aug 17 '17 at 13:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.