I'm trying to get to my phone's filesystem through USB in Wammu, but I'm stuck in the configuration wizard when it asks for a USB device name. After about an hour of Internet searching, here are the failed solutions I've already tried, starting with the relevant information returned by lsusb in terminal.

Bus 001 Device 003: ID 12d1:101e Huawei Technologies Co., Ltd.

So I tried opening Wammu through sudo wammu in terminal and inputting "/dev/bus/usb/001/003" as the device name, which returns:

Error opening device
Device /dev/bus/usb/001/003 does not exist!

and then "/dev/bus/usb/001/", which returns:

Failed to connect to phone
Description: Error opening device. Unknown, busy, or no permissions.<br>
Function: Init<br>
Error code: 2

Another proposed solution was to try "tail -f /var/log/messages" in terminal. But that only returned a "No such file or directory" message.

Seemingly relevant dmesg info:

[ 4739.716214] usb 1-1: new high-speed USB device number 8 using ehci_hcd
[ 4739.854137] scsi9 : usb-storage 1-1:1.0
[ 4740.854416] scsi 9:0:0:0: CD-ROM            HUAWEI T Mass Storage     2.31 PQ: 0 ANSI: 2
[ 4740.867051] sr0: scsi-1 drive
[ 4740.867806] sr 9:0:0:0: Attached scsi CD-ROM sr0
[ 4740.870464] sr 9:0:0:0: Attached scsi generic sg1 type 5

I don't know why it is coming up as CD-ROM. But there it is.

If you haven't noticed already, I'm an absolute beginner when it comes to Linux and terminal. So speaking to me like I'm a three year old is welcome if you can propose a solution.

I'm running Ubuntu 12.04 LTS, and the phone is a Huawei U1250. My computer is an Acer Aspire One D250/KAV60. Any help is much appreciated.

| improve this question | | | | |
  • UPDATE (9/9/2012 17:58) Tried Bitpim, and it could detect the phone when browsing for a port in the settings, but only shows an empty filesystem. Also tried gMobileMedia, but it just gets hung up when trying to connect. Next effort: Use a Windows PC to get the install files from the phone, then run Windows XP in Virtualbox (on this Ubuntu machine) and try from there. – Paul Sep 9 '12 at 22:02

you should try


Wammu is command line variant of Gammu,you'd know that.

This will give you a config file gammu you can find the device name in it.

Note the first two devices!


dave@hnphp006:~$ gammu-detect 
; Configuration file generated by gammu-detect.
; Please check The Gammu Manual for more information.

device = /dev/ttyACM0
name = Sony_Ericsson Sony_Ericsson_K790
connection = at

device = /dev/ttyACM1
name = Sony_Ericsson Sony_Ericsson_K790
connection = at

device = /dev/ttyS0
name = Phone on serial port 0
connection = at

device = /dev/ttyS1
name = Phone on serial port 1
connection = at

... etc..

| improve this answer | | | | |

You will find mounted removable media in /media. The directory used in /media will usually be the volume name, or the UUID (a long serial number) if there isn't one. This would be the filesystem.

I'm not sure the filesystem is exactly what Wammu wants however. If it really is looking for the device name, and if the device really is being recognised as as a CD-ROM, then the device name should apparently be


To get a list of device names on your system you should use the bash command:

| improve this answer | | | | |
  • /media is empty with the phone connected. blkid returns only the following known partitions of my computer's internal hard drive: /dev/sda1: UUID="91cb3a69-d0aa-472a-8165-b08752c5808b" TYPE="ext4" /dev/sda5: UUID="709c2657-d5c2-4e7a-a7b6-f858e5fd391b" TYPE="swap" /dev/sda6: UUID="f602dd61-1da8-4612-bd60-5f9e1122a099" TYPE="ext4" – Paul Oct 1 '12 at 5:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.