The problem started in the following way. I was using tasksel from the terminal menu that it shows when I simply do sudo tasksel. I select Lamp Server from the list and started to install all packages related to it. The problem is that by mistake my friend clicked on the termina close button and then on accept, closing the terminal and the activity tasksel was doing. I tried to install the lamp server again and found the following problem:

sudo tasksel install lamp-server  
tasksel: aptitude failed (100)

I should mention that I already have aptitude installed. So the error is not that I am missing aptitude. It worked before closing the terminal. How can I solve this?

  • 2
    Luis, I'd try an apt-get -f install first and look at the output, since it appears tasksel is having aptitude problems but isn't telling you what they are.
    – ish
    Sep 9 '12 at 4:23
  • @izx - +1 friend. That also worked. Sep 9 '12 at 6:02
  • I have Ubuntu 18.10 installed. None of these solutions worked for me. I had the completely remove tasksel using synaptic manager and then did a reinstall of tasksel. Mar 5 '19 at 17:31
  • If someone else still has this problem like me, I had to remove the libreoffice ppa from /etc/apt/sources.list.d/ for it to finally work.
    – Melvin
    Feb 7 '20 at 9:42

This is a long outstanding bug.


sudo apt-get update


sudo tasksel install lamp-server  

Oh and if this ever happens when you (re)install MySQL itself make sure to remove /var/lib/mysql.

edit: Found it on Launchpad from a report in 2007.

Nowadays you can also do

sudo apt-get install lamp-server^

The ^ is the equivalent of task select.


I know this thread isn't new and shiny and also this has already been answered but for those who encounter the issue again; I found that I received this error whilst trying to use tasksel to install whilst not having enough storage space left on my device. After removing some files and cleaning up the system of a little of junk, I tried again with success.

After clearing up I used:

apt-get -f install

As suggested by izx

After which, tasksel worked as usually expected.


I had the same issue, i solved it by these steps:

sudo rm -f /etc/apt/sources.list.d/ia32-libs-raring.list
sudo apt-get update
sudo tasksel install lamp-server

All done.


You can also get this error if you have some of what tasksel will install already installed. I had to run

sudo apt-get remove apache2 apache2-mpm-prefork apache2-utils apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-perl libdbi-perl libnet-daemon-  perl libplrpc-perl libpq5 mysql-client-5.5 mysql-common mysql-server mysql-server-5.5 php5-common php5-mysql

before it would work

Not the answer you're looking for? Browse other questions tagged or ask your own question.