I tried playing a WMV file in VLC and it told me something along the lines of Unable to play WMV3 files. Unfortunately there is no way for you to fix this. When I try to open the same file in MPlayer, it tells me an Internal data stream error occurred. I finally got it to start playing in KPlayer, but it is really sketchy; it's black and white and there's a few random blue lines down the middle of the video.

So is there any support for WMV3 files?

P.S. the same WMV file plays fine on my PC.

A different WMV file plays on Ubuntu fine.

  • So just to help eliminate issues were the w32/w64codecs installed.
    – damien
    Commented Sep 8, 2012 at 14:58
  • Not entirely sure... Commented Sep 8, 2012 at 14:59
  • PC is not the same as Operating System.
    – Aleksandar
    Commented Sep 8, 2012 at 19:12
  • I am Using wine to play Mplayer "The windows Version" to open WMV File ... It Works with a less of one second blank screen when forwarding , But in general it's very acceptable solution for me.
    – user146596
    Commented Apr 3, 2013 at 18:58
  • Your file probably, it's DRM protected. And in this case, you should remove drm protection first.
    – user296743
    Commented Jun 21, 2014 at 23:10

6 Answers 6


If you have installed The Restricted Extras package sudo apt-get install ubuntu-restricted-extras and you have tried to play the WMV video with VLC with no luck (I am assuming you did both of this already) then you have a problem with the file itself. You can do the following to check if the file is actually BAD and try to recover the parts that are OK:

On the same folder where the file execute the following in the terminal:

ffmpeg -i YourVideoFile.wmv -vcodec copy -acodec copy NewVideoFile.wmv

or the new version:

avconv -i YourVideoFile.wmv -vcodec copy -acodec copy NewVideoFile.wmv

If it starts throwing errors you know it was corrupt. The new file created will be better and you can play it but the corrupt or missing parts will be gone.

Normally if VLC can't read the file is because of 2 things:

  1. Streaming format - Which means you need to be connected to the internet or the progression of the video got lost in several parts somehow.

  2. Corrupt file - Which VLC would offer a way to fix it temporarily so you can view it.

If you already have the Restricted Packages which give you many compatible formats to encode/decode and also VLC which uses it's own native codecs and has the best way to solve video problems then most probably the problem is the WMV file. You can test another WMV to make sure.


vlc doesnt use any external codecs as its self contained and comes with all codecs, it should play wmv fine as it does here on all my machines.

VLC can be installed from the Ubuntu Software Center : VLC Install VLC

enter image description here

  • 7
    I have VLC installed, and it gives me an error. Commented Sep 9, 2012 at 13:06

Do you have the ubuntu-restricted-extras package installed? That might help you. Restricted Extras Package This will install some proprietary codecs also you can also add this ppa and install other W32 or W64 codecs Medibuntu this I hope helps. Here is a link That might help Here is another Link Here

  • Didn't work for me. Commented Sep 8, 2012 at 15:17
  • The w32 codecs package in the medibuntu repository should do the trick Commented Sep 8, 2012 at 15:36
  • 2
    The medibuntu repository is already as updated as the one in 12.04. The medibuntu repository was only better before 11.10. After that, all codecs were the same that came with Ubuntu 11.10 and later. Commented Sep 8, 2012 at 15:58

You could also move on from WMV files altogether.

sudo apt-get install libav-tools

Then just use:

avconv -v quiet -i input-filename.wmv ouput-filename.mkv

I'm assuming that SMplayer can play your WMV files but totem and VLC can not. so here's the solution:

  1. look for libavcodec extra in synaptic package manager and mark it for remove. it shows you a list of to be removed softwares and packages. press ok and do apply then log out.
  2. log back in and remove ubuntu-restricted-extras in software center. log out again.
  3. log back in again and install ubuntu-restricted-extras again. you will be able to play WMV files. tested on my ubuntu 14.04LTS.

If, as others have suggested, you have installed all the codecs and have ascertained that the file is not corrupt, the only unfortunate possibility left is that the file has some kind of DRM (Digital Rights Management) that makes it impossible to play on a Linux based system. As you note, it will play in Windows (presumably under Windows Media Player) as that is able to handle DRM. Also, as you note, other WMV files play fine on Ubuntu, so that may point to this particular file having some kind of DRM that limits the playing of the file.

This unfortunately may be the answer if installing, reinstalling the codecs and trying various media players fails to play the file properly.

  • I think it has something to do with the file not working is in Windows Media 9. The working WMV is in Windows Media 8. Commented Sep 9, 2012 at 20:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .