This is my weirdest experience with Ubuntu. I had upgraded from Ubuntu 11.10 to 12.04 many weeks back. Till y'day night everything was fine. When I started my PC today morning, weird things are happening:

  1. "Alt + Tab" is not working at all, it appears as of only "Tab" is taken; I am able to open terminal using "Ctrl + Alt + Tab" (shortcut) though and move between workspaces using "Alt + Tab + <arrow>"
  2. "super" (which has windows logo) key is not working. Typically when I press it, it displays "start menu" kind of stuff
  3. It doesn't show anything on the screen except the background; Generally I used to see top bar where apps like skype, date/time, power setting etc. used to reside
  4. Not able to see left side app bar, which displays several icons when mouse hovers on it or "super" key is pressed

I restarted my laptop but no luck. Presently I am going to terminal and opening everything using command line, e.g. "google-chrome &" and "eclipse &", which is very annoying.

I haven't touched any of my settings in several days or install any updates, except y'day I did "sudo updatedb" just to update the locate command. Please someone help in this regard.


Ok, I got it solved. From one of the Ubuntu forums, I found that there is something to do with Unity, I ran below commands and now everything is back.

sudo apt-get install unity
sudo apt-get upgrade unity
sudo reboot

[Note: However still few things are mystery to me. Why the things mentioned in question happened in first place?

I have a dual boot of XP + Ubuntu on a 5 year old laptop. In windows, I had 3 logins, with mine login being the primary one. I had installed a cisco vpn 1-2 days back and since then other 2 logins are not working. This problem has also appeared after that. Weird!]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.