6

Unity-greeter crashes, and constantly respawns, not letting me in. So, I configured auto login but that won't start anything except Unity session. I changed the lightdm.conf file to run Xubuntu but Unity still shows up. If I create a new user, it will start in Xubuntu just fine. I deleted my .conf XFCE prefs and that fixed nothing.

I can at least get in to the gtk login greeter but then the onboard keyboard does not show up. If I could get the onboard keyboard in the gtk greeter, I would be super happy. The onboard keyboard shows up in the Unity greeter just fine. But not the gtk greeter.

I don't have a solid keyboard because it is a tablet. So, I need the onboard in the greeter.

3
  1. Open "dconf Editor" program.
  2. From tree in left panel open com/canonical/unity-greater
  3. Chek onscreen-keyboard ckeckbox from right panel.

Have a nice time.

  • 1
    that's for the unity greeter right? I need to enable it for the gtk greeter – Joshua Robison Sep 8 '12 at 9:07
  • not working on 16.04 unfortunately – Mina Michael Oct 2 '16 at 2:52
3

With newer versions of lightdm (1.5.1?) there is a commented out line in the lightdm-gtk-greeter.conf file. The option at login is shown if you insert keyboard=whatever_to_start.

Example for onboard:

[greeter]

keyboard=onboard

see patch: https://bugs.launchpad.net/lightdm-gtk-greeter/+bug/905809

  • And you can toggle on-screen keyboard by F3 or in the accessibility menu. – jarno Oct 20 '15 at 18:04
  • Sometimes, when you want an on-screen keyboard, it's because you physically don't have a keyboard. Therefore pressing F3 may not be possible – Denys Vitali May 16 '17 at 9:46
1

There still seems like there is no way to get an on screen keyboard in the gtk greeter. Enabling the onscreen keyboard in the unity-greeter is somewhat easy but after a lot of research it appears that no one has done the development necessary to start an onscreen keyboard in the gtk greeter.

My particular problem however, does have a hack/fix. That is, I switched on "user does not need password on login"

This feature makes it so when the gtk greeter comes up, I only need to click on my user name to login. My user still has a password which I can use for package management etc. But for simply logging in , turning off the need to enter a password gives me at least a temporary fix...

I can at least get into my system without a keyboard.

  • I suppose this is not possible, if you have encrypted home folder. – jarno Oct 20 '15 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.