I am trying out live xubuntu on my samsung n150 (netbook, similar to eeepc). So far everything seems perfect, except for this one thing.

When I am clicking the mouse while moving the cursour, the click event is delayed. This is extremely annoying when i try to to move windows, because i end up clicking the window behind the window i am trying to move and thereby changing focus. This goes for all applications. I.e selecting text is difficult.

There is no lag in the cursor movement, just the click event. The click event is registered with the new mouse position, not the one when the mouse was clicked.

I tried searching for the problem, but all the other cases where either kind of different, or had no solution.

EDIT: After testing some more, here are some more information. The click doesn't occur until i stop moving the cursor. If I move the cursor smoothly around, the click never gets through. I have ubuntu netbook remix 10.04 installed, and have no problems with the mouse there.

EDIT2: Once I connected a usb-mouse, the problem dissappeared. Dragging now works perfectly with both the track pad and the usb mouse. I will update once I have installed xubuntu and figured out if this is a persistant problem.

EDIT3: I have installed, and the problem is still there. It dissappears when I have a second mouse connected however, and after I resume from suspend. My solution for now, is just to keep the dongle connected all the time.

EDIT4: It's been a while since I had this problem, and I've stopped using the machine. I think it was an annoying problem, however, and I will do what I can to help solve it.

Since somebody asked: the machine has 2 GiB of memory.

| improve this question | | | | |
  • I understand from your question that the problem occurs with ps2 mouse and not with usb mouse. Can you try another ps2 mouse to confirm that this is not a problem in hardware mouse? – Bhavin Doshi Apr 29 '13 at 16:54
  • @bkd.online It's a netbook, and I'm talking about the touchpad, not a ps2 mouse, though I don't know how the trackpad is connected internally. However, I've moved on to archlinux now, so it isn't really a problem for me anymore. (Do people even use ps2 mice anymore?) – bobbaluba Apr 29 '13 at 17:01
  • How much ram do you have in your machine? – Mitch May 2 '13 at 17:58
  • I had this on a previous install, try installing propietry drivers. – w4etwetewtwet May 3 '13 at 18:51

I had a problem once with my pad, sometimes it stopped working so I had to reboot to get it again. I solved it by unloading the mouse kernel module and loading it again. I don't know if it's much the same but you could try that.

sudo rmmod psmouse

sudo modprobe psmouse

| improve this answer | | | | |
  • 2
    This fixed the problem for me in Ubuntu 14.04. My problem was with a touchpad and was exactly the same as that described by the OP (bobbaluba). Unloading/reloading the psmouse module resolved it. – simonp Jul 5 '14 at 7:55
  • I was having the same problem with my touchpad, and just reloading the psmouse module fixed it for me too. – Iguananaut Feb 23 '16 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.