I have a MSI GT780DXR that currently is booting windows 7. I've been trying to dual boot windows 7 and ubuntu for some time now.

Here's specs that I think would make a difference

  • Windows 7
  • 500GB*2 RAID 0 hard drives. (Hardware RAID I'm not sure if it's a dedicated RAID card though) 7200RPM
  • Nvidia GT570M

Background: I tried to install 12.04 (64 bit) a few times but the Desktop live cd and pendrive boots with a black screen. I've tried wubi but it boots to a black screen as well. I then tried the alternative 12.04 (64 bit) and went through the installation all the way til partitioning. I let Ubuntu notice the raid setup and I setup my swap, /, and home drives, I used my free space to create the three partitions. I tried to resize the windows drive and it told me I couldn't and to be happy with my current setup. When I finally got past I got an error on installing GRUB 2 and decided to skip it and continued on to finish installation. When I tried to boot up I got an invalid partition table error. Windows recovery disc, and a GPARTED live cd couldn't find any hard drives. I ended up following advice and typed this into the recovery command prompt.

  • bootrec /fixmbr
  • bootrec /fixboot
  • bootrec /rebuildBcd

It worked and here I am now. The question is, how would I be able to dual boot windows 7 and Ubuntu 12.04 with this information? Thanks,

  • Could you please use a liveCD to install and run the boot-info-script tool and then paste the output here and put a link in your question? – adempewolff Sep 7 '12 at 3:50

I don't know for sure why GRUB failed to install on your hard-drive, but it may happen in some cases if there's not enough space between the MBR and the first partition. GRUB2 usually requires a little bit more than 30KiB but sometimes it needs more. This is especially true in RAID installations.

Assuming Windows resides on the first partition at the beginning of the disk, I suggest you move your Windows partition about 64K to the right and I believe that GRUB will be able to install on your MBR.

From the information above I'm unable to tell what is the reason for your partition table being corrupted, but it could be related.

Hope this helps.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.