0

Today I connected a second monitor to my computer. I set it up using nVidia's control panel, and all was working quite well, so I figured it won't be a problem to try Xinerama, just to see the difference between that and twinview. After enabling Xinerama and restarting the X session, I saw that I was logged into a Unity 2d session. I thought it was a problem with Xinerama, so I switched back to twinview, but it still logged me into Unity 2d. I tried disconnecting the second monitor, no luck: still Unity 2d. I tried changing GPU drivers and installing drivers from a separate ppa, and still I was logged into Unity 2d. Up until this point, I didn't have any problem logging into Unity 3d. It only happened after I tried using Xinerama.

I should note that I was doing all this while updates were going on in the background, so it could be something related to that, though I can't imagine what (I tried booting with another kernel, but no luck).

So what exactly happened? Did changing the mode to Xinerama triggered some other changes that I'm not aware of? Did these updates cause a certain malfunction in the driver? Is it something else?

0

It seems like I managed to solve the problem. Looking at /etc/X11/xorg.conf, I found that two things needed to be changed:

Option         "Composite" "Disable"

to

Option         "Composite" "Disable"

and

Option         "TwinView" "0"

to

Option         "TwinView" "1"

Apparently, switching to Xinerama disables composite, but switching back from it doesn't re-enable it. Also, TwinView was for some reason marked as disabled, though I did see two monitors. I hope this helps anyone else who runs into this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.