24

I've installed win7 on virtualbox on ubuntu 12.04. However, the full screen mode isn't perfect. I have black parts on both sides of the screen. I tried changing the resolution but nothing fits. Anyway to fix this?

By the way, my ubuntu is 64-bit (intel 4000 graphic card), and the my win7 is 32-bit. I'm not sure if this is the cause of the issue.

3
  • 3
    Have you installed the virtualbox extensions and guest additions?
    – amc
    Commented Sep 6, 2012 at 16:59
  • no I just installed it from the software center. So could you kindly tell me how do I get these extensions and additions?
    – stupidity
    Commented Sep 6, 2012 at 17:05
  • In 2024, this link helped me install those extensions. Afterward, there is an option View -> Auto-resize Guest Display. Commented Mar 18 at 22:29

3 Answers 3

39

You need to install the VirtualBox guest additions. Start Windows in your Virtualbox, and from the Virtualbox menu select "Devices -> Install guest additions"

enter image description here

Guest additions allow you a more seamless integration with the Linux desktop. Not only will you be able to have a better resolution and automatically adjust the resolution to the X window size, but in addition your mouse pointer will no longer be trapped by the Windows host, you will be able to share folders and more. See here.

2
  • 1
    I install that but nothing happened :(
    – Yuseferi
    Commented May 14, 2015 at 10:48
  • SO unfair. Doing it in ubuntu is soo freakin hard.
    – Confuse
    Commented Jul 19, 2015 at 8:11
6

Open main window of VM - Virtualbox.
Example 1

Click File (upper left) or Ctrl+G - Preferences Display
Set Hint --> Screen Size the same as main system.

Example 2

Done.
Back to main window, left side choose virtual system you want to start.

3
  • 3
    It does not work for me.
    – NoName
    Commented Jul 28, 2015 at 3:58
  • 1
    Changing the "Maximum Guest Screen Size" option to "None" worked for me - if that doesn't work, try enabling 3D acceleration as well. Commented Aug 5, 2016 at 1:34
  • works on mac. my resolution system preferences -> display -> scaled which was 1280x800. Changed virtual box display settings to "hint" changed the input to 1280x800. Started the virtual box and clicked full screen. I also had to click the display button in the virtual box and enable "Auto-resize Guest Display". Commented Mar 24, 2018 at 17:05
1

I had to rise videomemory and it worked!

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .