I installed OpenOffice on 12.04, and set it as the default utility for spreadsheets, but it doesn't run at all.

While trying to troubleshoot, I read that it is not recommended to install it alongside LibreOffice. I am about to uninstall OpenOffice because I don't know how to get it working, and LibreOffice is opening my spreadsheet just fine.

But just out of curiosity, I also read that I should try deleting .openoffice.org folder; but from where? I don't see it under /usr/lib, nor under my /home.


If you want to use Openoffice then you have to remove Libreoffice from your system. Open a terminal and then type

sudo apt-get remove --purge libreoffice*

It will remove LibreOffice completely. Then download the latest version of OpenOffice from here. Extract it in your desktop. Then open a terminal and type

cd ~/Desktop

cd en-US


sudo dpkg -i *.deb

After finished instaling type

cd desktop-integration

sudo dpkg -i *.deb

Now it is ready to go. It set default for your office files.

Enjoy. :)


openoffice folder is locate under /home/YOUR USERNAME/.openoffice

its hidden press CTRL-H to view hidden Folders!

When you have a file and or folder (ubuntu/ubuntu.txt) that you want hidden

All you have to do is start the name with a . it should look like so.

folder .ubuntu file .ubuntu.txt refresh the page F5 and your file/folder is hidden

  • Tried ctrl-h, also tried "ls -al $HOME | grep openof" but can't see .openoffi* file/folder. No wonder it is not working, but it seemed to install just fine. And I can even see its icons (OpenOffice.org.3.4 and OpenOffice.org.3.4.calc etc). – dn.usenet Sep 6 '12 at 7:09
  • ? lets start from scratch run this 'sudo apt-get remove openoffice*' – blade19899 Sep 6 '12 at 7:12
  • hello blade19899 - I am sorry but there just isn't enough time and incentive for me to try OpenOffice again when LibreOffice is working and I have read enough good things about it during the last hour. That word was unknown to me until today. While tryint to install OpenOffice, at 'sudo apt-get update' step, my laptop once hanged and I had to reboot it by pressing power key. Next time that cmd worked, then OpenOffice was installed smoothly but took a looong time, and then it didn't work. Very well, I will just stick with LibreOffice. – dn.usenet Sep 6 '12 at 7:20
  • OK. So you removed open office completely? – blade19899 Sep 6 '12 at 7:23
  • Yes, I removed it completely. While OpenOffice would rather that you installed it anyway and then perhaps deleted LibreOffice, neutral help-sites should mention first IMO that the two do not co-exist as of Sep-2012. – dn.usenet Sep 6 '12 at 7:40

I also had trouble getting it to work. I could see the file in the Opt/directory but it would not work. I tried two different downloads, nothing worked until I used the sudo remove command mentioned earlier. and repeated the dpkg commands as mentioned. I then opened my search tab and typed in open office, and found it there and opened the file. Once it opened I right clicked and hit the lock to launcher. Thank you Kaktarua for your post...

  • 1
    This does not seem to be a complete answer and probably should only be a comment. If you want to thank someone here, please just vote up the answer. – Adaephon Apr 25 '14 at 5:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.