I just went through a driver update. The OS froze, so I had to hard reboot the PC. Now I just get the login prompt in terminal. So, I tried to run startx.

codeError: API mismatch: the NVIDIA kernel module has version 304.43
but this NVIDIA driver Component has version 295.49`

I just got this error. I have to type sudo su then modprobe ndiswrapper to get my Wi-Fi to work, so step by step instructions after that would be greatly helpful.


This problem usually occurs when your nvidia drivers are not installed properly. Usually it is the result of installing the drivers from nvidia's website before or after the drivers that you get from the Ubuntu repositories (which is the recommended source, I might add).

To solve this, you need to remove the driver (if you installed it using the run file, you can uninstall it using the same file (see below)).

Or, you can delete the libraries associated with it (my apologies as I'm not on my nvidia powered laptop at the moment so I cannot check for certain as to which files you have to remove).

If you installed from nvidia's website, you can remove the drivers using:

nvidia-installer --uninstall

Optionally, you can run:

sudo apt-get --purge nvidia-current
sudo apt-get install nvidia-current
| improve this answer | |
  • tried both options, after running install nvidia-current, the terminal tells me I have the latest install. – Reinere Sep 6 '12 at 16:32
  • @Reinere: did you install the drivers from the nvidia website? – RolandiXor Sep 6 '12 at 21:11

To solve this I ran

sudo apt-get -purge nvidia-current-updates 

After that I ran

sudo apt-get -purge ndiswrapper

then I re-installed ndiswrapper, and reinstalled nvidia-current-updates.

Now typing this from my working gui.

Thank you Roland Taylor

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.