When I plug in a network cable, it is not recognized. The WI-FI is working properly, though.

ifconfig output:

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1645 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1645 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:206840 (206.8 KB)  TX bytes:206840 (206.8 KB)

wlan0     Link encap:Ethernet  HWaddr e0:06:e6:de:57:e7  
          inet addr:  Bcast:  Mask:
          inet6 addr: 2001:12f0:601:a921:98a2:3dd:3be8:c483/64 Scope:Global
          inet6 addr: 2001:12f0:601:a921:e206:e6ff:fede:57e7/64 Scope:Global
          inet6 addr: fe80::e206:e6ff:fede:57e7/64 Scope:Link
          RX packets:23892 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14676 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:30123226 (30.1 MB)  TX bytes:2189050 (2.1 MB)
  • try dhclient eth0 and see if it works.
    – green
    Sep 5 '12 at 19:13
  • I got the message: "Cannot find device "eth0" "
    – Izabela
    Sep 5 '12 at 19:18
  • post the output of ifconfig
    – green
    Sep 5 '12 at 19:23
  • @green7 edited the question with that info.
    – Izabela
    Sep 5 '12 at 19:26
  • what about ifconfig -a. Do you see something like eth0 of eth1 or something similar.
    – green
    Sep 5 '12 at 19:28

In my case (Ubuntu 12.10 with Inspiron 14z), just installing the linux-backports-modules-cw-3.6-quantal-generic package solved the problem. Here's the magic command:

sudo apt-get install linux-backports-modules-cw-3.6-quantal-generic

p.s.: This seems to be a duplicate of: 12.04 does not detect eth0(Atheros AR8162 )

  • I tried to install the package above but got the following message: E: Unable to locate package linux-backports-modules-cw-3.6-quantal-generic E: Couldn't find any package by regex 'linux-backports-modules-cw-3.6-quantal-generic'
    – Izabela
    Dec 26 '12 at 15:00

Download the drivers from this website: http://linuxwireless.org/download/compat-wireless-2.6/.

If you're not sure which one to select, download this one: http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2012-09-05-pc.tar.bz2.

First run sudo su and enter your password when prompted.

Then, follow these steps:

tar xjf compat-wireless-2012-09-05-pc.tar.bz2
cd compat-wireless-2012-09-05-pc
./scripts/driver-select alx
make install
modprobe alx


It might seem misleading to download the drivers because of the name, but give it a shot.

  • I will love to change the negative into an upvote if it works to the OP or if you give some reference or explanation about how does it work and why. Sep 6 '12 at 18:18
  • It worked!!! Just a note to someone following this thread: I had a permission problem, so remember to 'sudo'. Thank you @green7.
    – Izabela
    Sep 10 '12 at 11:17
  • Please accept the answer if you find it as correct. And also please tell where did you use sudo so that I can correct it.
    – green
    Sep 10 '12 at 11:21
  • The first time it did not work, if I remember well, it had a permission problem in ./scripts/driver-select alx. So I used "sudo su" and did the entire process again...
    – Izabela
    Sep 11 '12 at 2:06
  • I'll update the answer. :)
    – green
    Sep 11 '12 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.