Possible Duplicate:
‘apt-get’ does not work with Proxy

Everything I try with apt-get fails. I am installing Ubuntu server for the first time. It is version 12.04 LTS. When I run:

apt-get update

I get failed to fetch http://gb.whatever goes here......

If I run

apt-get install install build-essential

I get "unable to locate package build-essential"

I have looked at the sources.list but do not know what should and shouldn't be in there.

This is the current content of sources.list:

# See help.ubuntu.com/community/UpgradeNotes for how to upgrade to 
# newer versions of the distribution.
deb http://gb.archive.ubuntu.com/ubuntu precise main restricted
deb-src http://gb.archive.ubuntu.com/ubuntu precise main restricted

## Major bug fix updates produced after the final release of the
## distribution. 
deb http://gb.archive.ubuntu.com/ubuntu precise-updates main restricted
deb-src http://gb.archive.ubuntu.com/ubuntu precise-updates main restricted

marked as duplicate by Jorge Castro, Eric Carvalho, Eliah Kagan, Ringtail, hhlp Jan 8 '13 at 9:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Try sudo apt-get install -f. This fixed my problem similar to yours. You can test it afterwards by updating.

Hope this helps! :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.