I recent changed from Ubuntu to Xubuntu 12.04. The install worked great for a few days, but suddenly the left mouse button stopped working. The right click and scroll bars work fine.

After a bit of experimenting I discovered that the problem only happens when I set the session to Xubuntu at login. The mouse also works fine in my dual-booted Windows vista.

What could make my mouse stop working like that?

  • Can you post the contents of /etc/X11/xorg.conf? – Mitch Sep 5 '12 at 5:32
  • That file does not exist on my system. Weird. – giodamelio Sep 5 '12 at 5:40
  • Try sudo nano /etc/X11/xorg.conf – Mitch Sep 5 '12 at 5:47
  • Nope it opens me up for a new file. – giodamelio Sep 5 '12 at 5:58
  • 3
    X now automatically configures itself, see this wiki.ubuntu.com/X/Config, so you will not see /etc/X11/xorg.conf. To create a new one use sudo Xorg :1 -configure – Noble P. Abraham Sep 9 '12 at 8:15

Check if you have xserver-xorg-input-evdev installed on your system:

sudo dpkg -s xserver-xorg-input-evdev

If yes, do:

sudo add-apt-repository ppa:xorg-edgers/ppa  
sudo apt-get update  
sudo apt-get upgrade

If no, do:

sudo add-apt-repository ppa:xorg-edgers/ppa  
sudo apt-get update  
sudo apt-get install xserver-xorg-input-evdev


  • I see no reason why using the beta-quality xorg-edgers PPA would provide a solution to this. I doubt that his mouse driver is outdated. – Eric Sep 13 '12 at 12:23
  • Because this is a known issue, and this PPA will hopefully fix the problem. – Frantique Sep 13 '12 at 12:34
  • 4
    If this is a known issue, there should be a launchpad bug number. Since the problem only exists under the Xubuntu session, replacing the entire X stack sounds extreme. – Eric Sep 13 '12 at 12:46
  • Thanks for the upvote, this means that my method helped you? – Frantique Sep 14 '12 at 15:40

Your left mouse button might be remapped or disabled. Try adjusting the configuration or resetting to defaults in the Xfce control panel, as described here:


You can check the current mappings using the xinput command from the Terminal.

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Mouseemu virtual mouse                    id=14   [slave  pointer  (2)]
⎜   ↳ bcm5974                                   id=11   [slave  pointer  (2)]

Look for your mouse in the list and note its id, presented as id=x; e.g., 11

The use xinput again to get the current button map:

$ xinput get-button-map 11
1 2 3 4 5 6 7 

If the first number is "0", your mouse button 1 is disabled. Test re-enabling it with:

$ xinput set-button-map 11 1

Remember to replace "11" with the mouse's id from xinput list.

If this gets reset every time you login to your desktop, see if there's a file in your home directory called ".xinputrc" or a directory called .xinput.d/ containing files. Also see if there's an errant ".xinitrc" that might have xinput commands.


Try this command in terminal: sudo modprobe -r psmouse this command removes the mouse driver from the kernel, this should solve the problem, but if the mouse still doesn't work try this after the first command: sudo modprobe psmouse proto=imps and this should reinstates it. It is like of turning it off then on


Freantique's solution does not work for my Samsung N210 with Xubuntu 12.04. I find a solution that it works and I posted a step by step tutorial here: http://ubuntuforums.org/showthread.php?p=12489693#post12489693

  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Aditya Feb 3 '13 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.