I let my laptop upgrade to 12.04. And have no network afterwards. I went through all the articles I could find in google.

Right now, I can ping google, and yahoo, but not cnn.com for example or anything else. Firefox says it can't reach google.com or gmail.com (or anything, not even IP.


dns-nameservers                       <<<<<added
auto lo
iface lo inet loopback


#prepend domain-name-servers,;
prepend domain-name-servers;                 <<<<< tried both

/etc/NetworkManager/NetworkManager.conf with and without dns=dnsmasq commented out.

I can ping my wireless router and connect to it just fine.

Have tried proxy/noproxy.

This looks like After Upgrade to 12.04 - cannot connect to network but no answer there.

I would hate to do a fresh install. Any assistance appreciated.


I had the same issue. No more cable network after upgrade !!! The only solution I found is to remove the network manager and manually edit my /etc/network/interfaces file to have network using cable working;

Unfortunately, this solution has the drawback than nothing is display in notification area.

For information, a fresh install didn't solve the issue for me, so I guess there is some bug somewhere with the network manager.

to remove network-manager

sudo apt-get remove network-manager

A reboot may be required ...

edit the /etc/network/interfaces file

sudo gedit /etc/network/interfaces

and add the following lines depending on the network connexion you want to use (eth0, th1, etc ...)

auto eth1
iface eth1 inet dhcp
  • How do you remove the network manager? – Reg Sep 3 '12 at 20:40
  • I edited the answer to answer. – Manuel Selva Sep 3 '12 at 21:17
  • I tried the interfaces modification, after that reboot I could not use nm-tool. Removed the eth1 entry (which happens to be my wireless), rebooted and still says connect: Network is unreachable. Seriously, a OS update should not leave you in a mess like this. – Reg Sep 3 '12 at 22:53
  • So, I am back to a stage where I can ping all sorts of websites. but browsers still don't work. I do not have firestarter, so no idea why my connections get refused. – Reg Sep 5 '12 at 3:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.