Looks like I have a problem that has already been debated but non of the solutions provided did not work for me, so I'm asking this question again in hpes that someone can help me.

I'm running 12.04 64 bit version on Lenovo E520 with AMD Radeon HD 6600M and Intel HD graphic. I was using catalyst 12.6 driver downloaded and installed from http://support.amd.com/us/gpudownload/windows/previous/12/Pages/radeon_linux.aspx?os=Linux%20x86&rev=12.6.

However my system unexpectedly crashed with the "your system is running in low graphic card error". Since than I've removed the old ATI driver and installed the 12.8 version following their instructions with no problems, however the error still remains. If I use open source drivers I can use Ubuntu, but it slow to the point I can't even use gnome 3.

Previous solutions described do not work for me: How do I fix "Your system is running in low-graphics mode"?

Any help?


From the AMD wiki support site:

There are two basic types of hybrid designs. Older hybrid systems use a multiplexor (mux) to switch between GPU's. Newer systems (those with PowerXpress >= 4.0) are muxless. As far as I can tell, PowerXpress 4.0 started with RadeonHD 6000-series GPU's, and systems with older ATI GPU's have a mux, but don't quote that.

Intel/ATI Hybrids

TODO: Status unknown at this time

That line in 12.6 used to say that it was not possible to use Intel/AMD hybrid adapters with the fglrx drivers.

The best you can do is use the open source drivers or investigate further inside your BIOS and check if you can disable the Intel card completely.

  • help.ubuntu.com/community/BinaryDriverHowto/ATI There is a section just for ATI/intel cards, but I did notice that it says that this will not work with 12.8 version. I will try to reinstall 12.6 version and report back. – Janez Fouclait Sep 3 '12 at 15:11
  • What I am trying to say here is that no recent driver will work with your card, at least according to AMD. – Bruno Pereira Sep 3 '12 at 15:38
  • But I had installed 12.6 version and it worked without a problem from the time it was published to a few weeks ago when I first got the error. Now i do ont know if the driver was using full potential from my amd/intel hybrid, but as far as I am aware I was using amd card all the time. – Janez Fouclait Sep 4 '12 at 4:06
  • ok so I reinstalled 12.6 version following release note innstructions and it works. It seems I only have problems with the recent update. – Janez Fouclait Sep 16 '12 at 9:27
  • OK, so the problem pop up again. I am using win7/ubuntu 12.04. the 12.6 drivers worked perfectly after reinstall up untill today. I booted into ubuntu from win7 and voila- Your system is running in low graphic mode error again.... Frustrating..... Is there any progress on this problem- or help as to why is all of the sudden I have the same problem again?? – Janez Fouclait Oct 4 '12 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.