8

I've got an SSD drive for root and /home, and a larger HDD for storage. The storage disk is almost full, and there's a low disk space warning on startup. The warning doesn't have any "don't show again" option, only "ignore" and "examine". It also doesn't go away but sticks on the screen until the ignore button is clicked, so it's very annoying in addition to being competely unnecessary.

I tried unselecting the storage HDD in baobab's settings, but that didn't have any effect. I also tried gconf-editor, and looked for apps -> gnome_settings_daemon -> plugins -> housekeeping, but there is no "plugins" under "gnome_settings_daemon". Only "gtk-modules" and "keybindings".

  • Still no answer for newer Ubuntu Versions! – rubo77 Mar 25 '18 at 7:40
6

Found via https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/881376

gsettings set org.gnome.settings-daemon.plugins.housekeeping active false

  • It's seems the key is no longer there. Key path seems to be now apps.gnome_settings_daemon.plugins.housekeeping, but there's no key active (indeed there are any key). I created it and it doesn't work. I created also free_size_gb_no_notify and it also doesn't work. I'm using gnome 3.26. – juanmah Oct 21 '17 at 2:37
  • This doesn't work anymore. – Aaron Franke Jun 21 at 0:13
-2

First check your free space with df -h

This answer will not try to stop the warning, but maybe you are better off, freeing some space, for example you can free space used by apt-get:

sudo apt-get autoclean
sudo apt-get clean
  • 2
    Thanks, but I'm not trying to free space, and I doubt apt-get would free space on the storage drive anyway – grimripper Sep 4 '12 at 5:19
  • Here I created a script to uninstall more useless stuff: askubuntu.com/a/576431/34298 – rubo77 Mar 25 '18 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.