1

Just installed Ubuntu 12.04 and I can't connect to my wireless network. My network doesn't even appear. I have a message it says:

device not ready firmware missing.

This is what I get when I run, lspci -nn | grep 0280 in terminal:

03:00.0 Network controller [0280]: Broadcom Corporation BCM4331 802.11a/b/g/n [14e4:4331] (rev 02)

Please help me to get this working.

1

3 Answers 3

3

You need to manually install the b43 driver.

Open Ubuntu Software Centre and search for b43 and click to install it.
Then reboot and the wifi should be working.

enter image description here

5
  • after installation now don't even show me any option for wireless conection!!! Sep 2, 2012 at 10:56
  • That is the right driver for the card. Have you rebooted the computer and removed the LAN cable? Also is your computer fully updated - if not plug in the LAN and install any updates that may be available. Sep 2, 2012 at 11:03
  • I reboot the computer and i just check for updates and is up to date!!! Sep 2, 2012 at 11:24
  • Are you using a mac? I googled and found some bugs filed against that card on macs, and some additional instructions to get it working, have a look at this link for details : ubuntuforums.org/showthread.php?t=2011756 and here is another link with a different solution : askubuntu.com/questions/181455/… Sep 2, 2012 at 12:07
  • yes I'm using a macbook pro maybe I should mentioned before sorry by that!!!! :p I have used the tutorial from the first link and worked like magic!!! thank you so much all of you for your help you guys are incredible!!! Sep 2, 2012 at 12:25
2

Try running jockey-gtk and see if it offers you to install a proprietary driver for your network card. You will need an Internet connection to install the driver, so connect your PC to your home network with an ethernet cable.

Here is what the jockey-gtk utility looks like, the proprietary driver for your card should be in this list:

jockey-gtk interface

4
  • nothing appear an this is what I get in terminal:(jockey-gtk:2185): Gtk-CRITICAL **: gtk_icon_set_render_icon_pixbuf: assertion icon_set != NULL' failed (jockey-gtk:2185): Gtk-CRITICAL **: gtk_icon_set_render_icon_pixbuf: assertion icon_set != NULL' faile Sep 2, 2012 at 10:53
  • Did you type it in the terminal emulator or in the tty console? Because this is a GTK application, which means that you should be in a desktop environment when you launch it. If you are in a tty console, you can use the jockey-cli utility. I updated my answer so that you can see what the program should look like.
    – jeremija
    Sep 2, 2012 at 11:07
  • I type in terminal emulator. Sep 2, 2012 at 11:26
  • Wen the window open don't show any driver. Sep 2, 2012 at 11:39
0

The official Broadcom STA/wl driver DOES NOT support monitor mode. You are using the Broadcom STA (wl) official driver; this does not support monitor or promiscuous modes (regardless of whatever airmon-ng tells you.) For this you need the b43 driver, which can be installed with

sudo apt-get install b43-fwcutter firmware-b43-installer

You can unload one and load the other with

sudo rmmod wl; sudo modprobe b43     # or vice versa 

Note that b43 and wl have their own advantages and disadvantages, so you may want to google before choosing one or the other.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.