0
root@m-laptop:/home/m/Desktop# apt-get -f install libc6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libc6 is already the newest version.
libc6 set to manually installed.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  virtualbox-4.1: Depends: libc6 (>= 2.11) but 2.9-4ubuntu6 is to be installed
                  Depends: libcurl3 (>= 7.16.2-1) but it is not installable
                  Depends: libpython2.7 (>= 2.7) but it is not installable
                  Depends: libqt4-network (>= 4:4.5.3) but it is not installable
                  Depends: libqt4-opengl (>= 4:4.7.2) but it is not installable
                  Depends: libqtcore4 (>= 4:4.7.0~beta1) but it is not installable
                  Depends: libqtgui4 (>= 4:4.7.0~beta1) but it is not installable
                  Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
                  Depends: libstdc++6 (>= 4.6) but 4.3.3-5ubuntu4 is to be installed
                  Depends: libxml2 (>= 2.7.4) but 2.6.32.dfsg-5ubuntu4 is to be installed
                  Recommends: libsdl-ttf2.0-0 but it is not installable
                  Recommends: dkms but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@m-laptop:/home/m/Desktop# 

I ran the command earlier as : dpkg -i virtualbox-4.1_4.1.18-78361_Ubuntu_oneiric_i386.deb and was trying to install vbox in 9.04

2
  • actually ran the command earlier as : dpkg -i virtualbox-4.1_4.1.18-78361_Ubuntu_oneiric_i386.deb and was trying to install vbox in 9.04
    – mohit
    Commented Sep 1, 2012 at 18:38
  • 1
    If you haven't already tried it you might run " sudo apt-get -f install" to see if it clears up any of the dependency problems.
    – Kelley
    Commented Sep 1, 2012 at 18:39

1 Answer 1

1

It looks like you are using Ubuntu 9.04 "Jaunty Jackalope" (which isn't supported any more) and you have tried to install the package virtualbox-4.1 that requires at least Ubuntu 10.04.

Remove the package and upgrade your system.

4
  • but if i want to keep the 9.04 then? i have the bootable pendrive for 12.04 ready so can i install these library files through it or by internet? and get vbox working?
    – mohit
    Commented Sep 1, 2012 at 18:57
  • ACTUALLY i want to install the OS which takes least memory like 9.04 and run vbox and media players only in this OS(host OS)
    – mohit
    Commented Sep 1, 2012 at 19:04
  • 1
    Mixing packages from different version of Ubuntu usually doesn't work. As in this case a different version of libc is required which is a central part of the system and would need you to update most other packages anyway. Commented Sep 1, 2012 at 19:06
  • 1
    If it is just for the memory try Lubuntu 12.04 Commented Sep 1, 2012 at 19:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .