I have just updated to 12.04 and I have only one choice of screen resolution now, and it is incorrect (1024x768). I believe the correct resolution for my display is 1366 x 768. It is on an Acer Aspire 5338 with Intel GMA 4500M graphics.

In the Diplays window, it is detecting my display as simply 'Laptop'. When I first restarted after the upgrade the screen was scrambled, so I had to restart in recovery mode and select 'Run in failsafe graphic mode', which solved the scrambled screen problem.

Running the command xrandr gives:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768 maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768        0.0*

In System Details, it is reporting the following:

Graphics: VESA Intel(r) Cantiga
Graphics Driver: VESA Intel(r) Cantiga Graphics
Experience: Standard

Any help would be gratefully received as it is driving me mad trying to resolve it.


Richard, xrandr prompted the same to me after upgrading to 12.10. I could solve this issue through removing my previously installed proprietary graphics driver ...

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

... and using the default open-source driver.

sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

(source: http://wiki.cchtml.com/index.php/Ubuntu_Lucid_Installation_Guide#Removing_the_Driver)

Wish you great success, too.

| improve this answer | |

OK guys, after trying and trying with KMS (kernel modesetting), Xorg.conf all kinds of tutorials on google and everywhere... I have THEE most stupid and easy fix that I found today :P

I have an old Dell Dimension with an Acer X173W monitor (2 CD machine). It had a resolution of 1024x786 which was horrendous. It is supposed to have 1440x900. On the front of the Acer there are menu options. Pan through them til you see "re-set" apply the re-set.

It will "adjust itself". Now go back onto your machine, go to settings>display.... and voila!!!

You will now see many different resolutions to choose from. Choose the one you want, it will ask you if you wish to keep, if you like, select "yes keep this setting" BAM! done!!! \o/

Hope this solves many headaches. Works for Mint/Ubuntu... and what Im running on the Dell is a new distro called SalineOS. Im running Mint 14 Cinnamon on this Toshiba lappy :P

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.