Sorry to be asking this, but I have read quite a few posts and articles a lot of places wrt the issue I am having, to no avail. I am trying to get a Second Life Viewer (Firestorm) to run, and just keep getting the '64-bit error message' it throws. I have installed every 32-lib I can find, still doesn't work. I think I am surely missing some setting somewhere, or running Firestorm from the wrong place, or something, but I have no idea what.

FWIW, Firestorm loads but doesn't behave right in the 32-bit version, either. I have actually tried several Linux distros, 32 and 64-bit. Mint 32-bit runs it straight off, and Mint 64-bit throws the '64-bit error'. openSUSE, any version, won't run it at all. Oh, and all the other SL viewers I have tried behave the same way.

I am beginning to wonder if my set-up just doesn't like Linux.

Here is my system info:

  • CPU: Intel(R) Core(TM) i5 CPU 750 @ 2.67GHz (2661 MHz)
  • Memory: 4026 MB
  • OS Version: Linux 3.2.0-29-generic-pae #46-Ubuntu SMP i686
  • Graphics Card Vendor: ATI Technologies Inc.
  • Graphics Card: ATI Radeon HD 5700 Series

I appreciate any help anyone can give me!


This shouldnt require any extra steps. 32 bit programs should run by default in a 64 bit environment with no issue, Of course the opposite is not true. If a 32 bit program wont run in your 64 bit system, I suspect there is a different issue. Try starting the program in terminal & watch for any errors. (strating a program in terminal simply requires opening a terminal, typing the program name, & hit enter). If any errors appear, paste them in your question & I will try to help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.