I'm having trouble with Compiz, since I upgraded to 12.04. I have an nvidia-card (GeForce 9600M GT). In general Compiz works, but it has performance issues and rendering problems as in the following screenshot 1, that make usage impossible.

According to my research, the loose-binding option could help solving the problem. Unfortunately this is unavailable to me, as the Compiz Options in the Fusion Icon are greyed out.

Additionally the command-line argument --loose-binding for Compiz provokes an error that this option is unavailable. Same goes for the --indirect-binding option.

How to make those options available or solve the rendering problems in general?

2 Answers 2


Try this to fix most nvidia errors

Open a terminal and add the nvidia PPA

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

Then update the repos

sudo apt-get update

And finally update the drivers

sudo apt-get dist-upgrade

Now reboot, and when you log back in you will have a working, up to date nvidia driver in Ubuntu ;)

You could then reinstall compiz with

sudo apt-get install --reinstall compiz

Good luck

  • I tried both of this out and my nvidia drivers are now updated to version 304.43. Unfortunately it did not change anything regarding the compiz issue. Thank you for the advice though.
    – Fabaroo
    Sep 1, 2012 at 11:51

It sounds like your Nvidia drivers are not working, or not installed. As a result there is no extended graphic support and no graphic bells and whistles, meaning Compiz and Fusion cannot work.

In some versions of the Nvidia drivers there was/is a bug and due to a missing header file, the driver is not installed properly, and not working.


sudo apt-get remove nvidia-current

then reboot and check Compiz (when I had a similar problem, the removal solved the problem). if no change, reinstall:

sudo apt-get install nvidia-current

then reboot and check Compiz again. If still no luck, maybe one of the following links can help:

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/993506 https://askubuntu.com/questions/150601/why-nvidiabl-module-is-not-working-in-precise

Hope that helps!

  • I did this after updating the drivers as advised in the other suggestion. It did not solve the problem. I don't have the impression the drivers are not working, because apart from compiz the fancy opengl stuff works perfectly fine (e.g. glxgears or the game Psychonauts). Still, thank you for helping.
    – Fabaroo
    Sep 1, 2012 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.