2

This question already has an answer here:

I recently installed 12.04 LTS after not using any Linux distro for several years. My Canon MP280 worked perfectly as far as printing goes and I was even able to set it up on a Samba share and print from a Windows 7 machine.

However, when I open Simple Scan it does not detect a scanner. I did find some instructions online but the scanner is still not recognized in Simple Scan even after installing a couple .deb packages from the Canon site.

I also couldn't seem to find the ScanGear package after installing those .deb packages as well but I haven't had a chance to delve fully into it.

marked as duplicate by Takkat, Eric Carvalho, Rinzwind, Fabby, v2r Feb 21 '15 at 17:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

I solved my own problem. I went to the Canon printer driver daily site at

and then added the PPA to my sources using the instructions there:

sudo add-apt-repository ppa:michael-gruz/canon-trunk

I then updated my lists via sudo apt-get update. The OS then prompted me to install 4 new packages which I did and everything seems to be working now!

1

Scanner will work for me, but only if I run 'scangearmp' from terminal as root.

Not the answer you're looking for? Browse other questions tagged or ask your own question.