I have a Canon i-sensys MF4410 laser printer. I am running a dual boot system with Windows 7 and Ubuntu 12.04. The printer works in Windows and Ubuntu sees it when I attempt to add a new printer but I cannot get it to work in Ubuntu. (It previously worked fine under Ubuntu 8.?) I have tried installing (and un-installing) the driver cque-en but, although Ubuntu sees the printer, it does not find the driver.

I have even tried using the generic laser and 'text only' drivers but these do not work.

If anyone can help and it requires using terminal please give detailed instructions.


Downloading and installing the drivers provided by Canon via their website may be the best solution.

To save you some time I went and found them for you, you can download their drivers using this wget command:

wget http://files.canon-europe.com/files/soft40355/Software/o1113enx_l_ufr220.zip

Then just extract this archive and install the appropriate .deb package located in one of the folders from the archive.

If that doesn't work you can try downloading them from the website yourself:


|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.