This is a recurring problem and occurs a few times a week.

I have an external hard drive which is hfs+. Every couple of weeks, for no obviuous reason, when I mount it by pluggin it in to my Ubuntu 11.10, it is read only and I can't copy any files into it.

I gksudo nautlius and change the ownership and it magically works in some time. But returns to the read only state soon in a few hours-days without any rhyme or reason.

Right now my fstab doesn't have any entry for my hard drive. What gives? What in the world is going on with Linux/HFS+? This is frustrating. I can't reformat my hard drive because I have almost a terrabyte of data in it and no receptacle to hold it while I reformat it.


This question was asked and answered over at superuser.com:

You need to turn off the journaling if you want to write to it from Ubuntu. Ubuntu only has support for writing to non-journaled HFS+ volumes.

On your Mac:

  • Open Disk Utility under Applications -> Utilities
  • Select the volume to disable journaling on.
  • Choose Disable Journaling from the File menu. (On later Mac OS versions you'll have to hold down the option button when you click the File menu. Or if you like Apple+J)

Journaling is a feature that helps prevent file-system corruption in case of sudden loss of power or major crash and also helps speed recovery during a filesystem check. Just so you know what you will be disabling. You can use a file-system without journaling, you just might have to wait longer and deal with more problems if your computer crashes or loses power.

Support for read+write access with journalling for HFS+ partitions is still in progress. You can forcibly enable it with recent kernels, but it's still considered unsafe [source].

  • I have done this long ago.. It reverted to the old problem of being read only. – dearN Aug 31 '12 at 2:19
  • I don't know what further to suggest then. Wikipedia notes that you cannot use Apple Time Machine after disabling journaling. Maybe you tried to run Time Machine and it enabled journaling as a result? Just a wild guess, and I don't know much about Macs. – thomasrutter Aug 31 '12 at 2:21
  • No, I have never used time machine. – dearN Aug 31 '12 at 2:21
  • Is there any way I can force mount with read access? I tried force rw with sudo mount but that didn't work. It said that according to mtab my disk was already mounted. Sure... but without write access. – dearN Aug 31 '12 at 2:23

I have an external USB drive that is formatted as hfs+. Sometimes it mounts as a read-only volume. I think that this is a safety feature. I believe that it indicates that the drive has been mounted improperly. If this is the case then you simply run fsck and then remount the drive. It should mount with read/write access if fsck returns no errors.


sudo fsck.hfsplus /dev/sdXY

This answer is derived from j.biddy in this thread: http://ubuntuforums.org/showthread.php?t=1696688

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.