I'm attempting to install Ubuntu 12.04LTS, 64bit onto a Dell Inspiron 15R laptop. I've shrunk down one of the windows partitions and even used GParted to format the vacant space as ext4.

However, the install disk simply does not present any options when it comes to the partitioning step. What I get is a non-responsive blank table.

As well as the above, I've changed the BIOS settings so that USB emulation is disabled (as per Can't install on Dell Inspiron 15R), and changed the SATA Operation setting to all three possible options.

Anyway, the install CD will bring up the trial version of Ubuntu, and if I open terminal and type sudo fdisk -l, I get this:

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xb4fd9215

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63       80324       40131   de  Dell Utility
Partition 1 does not start on physical sector boundary.
/dev/sda2   *       81920    29044735    14481408    7  HPFS/NTFS/exFAT
/dev/sda3        29044736  1005142015   488048640    7  HPFS/NTFS/exFAT
/dev/sda4      1005154920  1953520064   474182572+  83  Linux

Disk /dev/sdb: 32.0 GB, 32017047552 bytes
255 heads, 63 sectors/track, 3892 cylinders, total 62533296 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb4fd923d

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048    16775167     8386560   84  OS/2 hidden C: drive

If I type sudo parted -l, I get:

Model: ATA WDC WD10JPVT-75A (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      32.3kB  41.1MB  41.1MB  primary  fat16        diag
 2      41.9MB  14.9GB  14.8GB  primary  ntfs         boot
 3      14.9GB  515GB   500GB   primary  ntfs
 4      515GB   1000GB  486GB   primary  ext4

Model: ATA SAMSUNG SSD PM83 (scsi)
Disk /dev/sdb: 32.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  8589MB  8588MB  primary

Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Error: Can't have a partition outside the disk!

I've also tried a Kubuntu 12.04 and Linux Mint install disks, with the same problem.

I'm completely lost here.


I encountered the same problem with my new inspiron 17R. Tried both 10.04 and 12.04. Resolved issue after reading this thread:


"If the disk has been used in RAID, it has raid meta data remains. In this case ubuntu ignores it thinking you are using it in a raid array.

If you ARE NOT using any RAID, remove the meta data from live mode with: sudo dmraid -E -r /dev/sda"

Not sure why my drive had RAID meta data information.

Maybe it got there during manufacturing?

Maybe Windows 7 uses it for something?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.