I am using a Samsung Chronos 7 laptop with the following sound setup:

$ head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 <== 
Codec: Realtek ALC269VC 

==> /proc/asound/card0/codec#3 <== 
Codec: Intel CougarPoint HDMI 

With the stock ALSA that comes with Ubuntu 12.04, I do not get any sound out of the headphones when I plug them into the headphone jack. After plugging the headphones in, I have to manually use Alsamixer to increase the volume, so that the headphones become usable. I have been told that this issue is due to my sound chip not being supported in the ALSA version that ships with Precise. A similar question at AskUbuntu and the Ubuntu Community Documentation point me to the ALSA DKMS installation.

After installing the dkms module of yesterday's ALSA snapshot and rebooting, the headphone issue is indeed solved. I can now plug my headphones into the jack and instantly have sound on them. However, now I have tons of static noises and crackling when playing sound in VLC player or Skype (Firefox HTML5 playback seems to be fine, unless a Skype sound interferes with it). Is there a fix for this? I tried adding the Alsa PPA and installing the latest ALSA package proper, but that didn't have any effect, only the Alsa DKMS package seems to solve the headphone issue.

Crackly sound with Skype on Ubuntu

Open up “/etc/pulse/default.pa”, find “load-module module-udev-detect” and add to the end “tsched=0″, which will disable timer-based audio scheduling. It should look like:

load-module module-udev-detect tsched=0

*NOTE: You need to have elevated privileges to alter this file you can use the built-in text editor called nano from a terminal. Use this command to open it:

sudo nano /etc/pulse/default.pa

Save (press ctrl+x then enter to save using original filename) and execute

pulseaudio -k && pulseaudio --start

to restart ALSA

I has the same issue as i m using 13.04, so mine is fixed with this fix.

I am using 13.04 so mine is load-module module-udev-detect use_ucm=0 and i have added the tsched=0 in the end and now it is load-module module-udev-detect use_ucm=0 tsched=0

  • I just isntalled Lubuntu 13.04 and am having some crackly audio problems. However, the only file in the "/etc/pulse" directory is "client.conf"; there's no "default.pa". Any tips? – Quinn Culver May 10 '13 at 17:11
  • i do not know about lubuntu – Qasim May 10 '13 at 17:35

A recent update to the pulseaudio package included with Ubuntu 13.04 (Raring Ringtail) and Kubuntu 13.04 may be causing some users to experience a persistent background noise, or hum. It appears that this particular bug will affect VLC, Skype, and possibly other applications which emit audio. This problem is primarily affecting Intel-HDA (high definition audio) chipsets and ALSA sound drivers in regards to "glitch-free" PA (pulse audio).

Modify the following line in /etc/pulse/default.pa:

Change load-module module-udev-detect to load-module module-udev-detect tsched=0

Source and Complete Guide: UbuntuLinuxGuide.com

  • Please avoid posting the same answer in more than one place. When tempted to do so, this typically means: (1) the answer should be customized to account for what is different about the different questions, (2) one question should be flagged for closure as a duplicate of another question (you can flag posts with 15 reputation), (3) the answer should really be a comment, or (4) the answer should be posted in the most appropriate place, and one-line comments posted on the other questions summarizing and linking to it. – Eliah Kagan Jul 24 '13 at 3:46

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.