13

I'd like some help to fix another unity issue. After last update, my system broke. For example, when I execute a 'ls' command, the screen breaks and does not show anything. Sometimes, just the beggining is shown.

How can I fix it?

I don't want use another X, for now...

Thanks

5
  • 1
    Try to log in with Unity 2D (that does not use Compiz)
    – January
    Commented Aug 30, 2012 at 12:12
  • It does not work for me.. This problem does not happens in "Gnome no effects" mode only
    – jordan
    Commented Aug 30, 2012 at 12:24
  • 1
    This did for me months ago askubuntu.com/questions/154112/…
    – kmassada
    Commented Aug 30, 2012 at 12:29
  • Hello, I get this issue fixed!
    – jordan
    Commented Aug 30, 2012 at 12:52
  • 1
    Hello, I get this issue fixed! When I was trying to re-install my drivers with commands: sudo add-apt-repository ppa:sarvatt/intel-sna && sudo apt-get update && sudo apt-get dist-upgrade -y sudo add-apt-repository ppa:xorg-edgers/ppa && sudo apt-get update && sudo apt-get dist-upgrade -y A message was showed to me, so I did follow the tip and create a xorg.conf with with content: Section "Device" Identifier "intel" Driver "intel" Option "AccelMethotd" "uxa" EndSection Just it! I hope it helps! Thanks
    – jordan
    Commented Aug 30, 2012 at 12:59

3 Answers 3

14

Before removing Compiz you might wanto to try and reset it

1.Press Alt + ctrl + F1

2.Login using your username and password

3.Reset compiz by executing gconftool-2 --recursive-unset /apps/compiz-1

4.Reset unity , by executing unity --reset

5.Optionally you can reset launcher icons by executing unity --reset-icons

6.Press Alt + ctrl + F7 to get back to login screen. However I recommend a restart by executing sudo reboot. Let us know if it worked.

Cerdits to Web-E

To remove compiz and compiz packages type this in a terminal:

sudo apt-get purge compiz compiz-plugins-main-default libcompizconfig0

Warning: Removing compiz also removes the packages unity & ubuntu-desktop.

Warning: Removing libcompizconfig0 also removes ubuntu-tweak.

Thus you will lose the ability to log into the unity or unity-2d desktops.

Source

More info here: How can I remove and re-install Unity?

And here: Ubuntu 12.04. Compiz Failure. Computer has nothing to use

0

You can try Ubuntu Gnome. It doesn't use Compiz and still has as much, of not more eye candy as Ubuntu.

I have a multi boot system, and Ubuntu Gnome is one of them.

0

Instead of trying to delete compiz, which will have many dependencies issues with Unity and Gnome etc, how about just going ahead to install other Window Manager? The last time I tried to uninstall / delete Unity/compiz, I ended having to reinstall the entire OS.

For example: Xubuntu:

apt-get install xubuntu-desktop.

Or you can try i3, awesome, lxde etc.

And then at the login screen, select the appropriate windows manager - making sure you avoid Gnome, Unity or compiz.

After logging in, "ps -ef" and you can easily verify that compiz is not running.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .