I have installed Samba onto Ubuntu 12.04 Server but I can't login as it says my password is incorrect but I am the only user so there are no other passwords.

I have tried changing the password through the terminal but nothing is working.

Any advice for a newbie is very much appreciated.


2 Answers 2


This is how I resolved the issue.

from a terminal box type sudo smbpasswd -a <user name> you'll be asked for a password, use your normal one

then you'll be asked for a new "SMB" password... sync it with the usual one by typing in you password again then confirming it...

Shares were instantly accessible from Win7 using Ubuntu user name and password

  • THANK YOU!! I encountered this same problem on Linux Mint 17.2! Now to figure out how to get anonymous browsing working. ;-) Dec 21, 2015 at 10:51
  • Solved my problem too. VIrtualBox; Host: OS-X-10.11; Guest: Ubuntu-14.04. Feb 4, 2016 at 18:23
  • 4
    Isn't this the exact answer you got from @ender?, three months later?
    – Gauthier
    Oct 30, 2016 at 20:28

What did you use to change your password? Samba does not automatically use your user password, your first have to add your user to samba with smbpasswd -a <user>

*from http://www.cyberciti.biz/faq/adding-a-user-to-a-samba-smb-share/

  • I opened the terminal and typed smbpasswd -a NAME
    – Luke
    Aug 30, 2012 at 11:27
  • i then added a password but i cant get it to work
    – Luke
    Aug 30, 2012 at 11:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.