I recently re-imaged my Dell PC to dual-install Windows 7 and Ubuntu 12.04.1 LTS. The dual-boot was a success, since I was able to start whichever OS I wanted.

Now, I installed some software (the OpenJDK package) on the Ubuntu side of the PC. Upon restarting Ubuntu, I unfortunately lost the ability to choose the OS that I wanted to run (i.e., Ubuntu).

Ordinarily, I'd expect to: 1. Hit the power button 2. A menu (Grub?) shows up listing all OSs installed in the PC (namely, Win7 and Ubuntu) 3. Choose which OS I want and hit enter. bingo.

The problem is that I don't see that menu (step 2 above). Instead, windows automatically starts, even when I hit F12 to see the boot options, none of which I understand.

Your help would be great! Thanks! - Kiptoo


2 things could be happening, the first that Grub isn't installed. Grub is the boot menu that lets you switch between two OS.

if that is the case you need to take a look at https://help.ubuntu.com/community/Grub2/Installing

if grub is installed however, after bootup if you see a purple screen press ESC, it will show the menu, or another way of showing the menu is to hold the SHIFT key. boot into ubuntu and http://www.howtogeek.com/65974/how-to-easily-change-your-dual-booting-pcs-default-os/

  • thanks, @kmassada. grub is installed, but holding down the SHIFT key doesn't seem to help. I inserted the USB disk with the Ubuntu image and I could see the grub menu, but when I remove the disk the menu disappears. does that mean that my partitioning was perhaps incorrect?
    – kip2
    Aug 29 '12 at 21:22
  • If you are able to see grub, boot into ubuntu and troubleshoot it from there, if you install grub on a disk you aren't supposed to, it won't even boot.
    – kmassada
    Aug 30 '12 at 11:34

You should try holding down the Shift key after you would hit F12, example, don't hit F12 just hold down Shift and it should bring up the grub menu.

This should allow you to choose which option to boot into, if that works you should boot into Ubuntu and run the Startup Manager to change the timeout.

The command to run Startup Manager should be startup-manager iirc, in case you don't have it installed. From there it should be self explanitory as you only need to change the timeout to something like 3 seconds. Now when you close this is should update grub automatically.

  • thanks, @l300lvl. holding down shift after hitting F12 doesn't help either. also, I read that startupmanager is not maintained anymore (at least for the 12.04 Ubuntu family), and doing sudo apt-get install startupmanager results in a "package not found" error. I will have to look into whether the disk partitioning worked right
    – kip2
    Aug 29 '12 at 21:25
  • I'm sorry I wasn't more clear, try installing startup-manager that should have been the name of the program. If not open the Software Center or Synaptics and type in startup manager. Glad you got this solved though.
    – l300lvl
    Sep 1 '12 at 1:44

Based on your comment, "I inserted the USB disk with the Ubuntu image and I could see the grub menu, but when I remove the disk the menu disappears. " it sounds like grub's boot sector was installed to the USB drive rather than to your internal drive. If that is the case, you should solve it by booting your Ubuntu installation (by plugging in the USB drive) and running sudo dpkg-reconfigure grub-pc.

This command will ask you some questions, the first two will be about the "linux cmdline" leave those at their defaults (the first may be blank, that's normal) and continue by pressing Enter. When prompted for install devices, select your internal drive (something like "sda" or "sdb", but not a partition like "sda1" or "sdb5") as an install device. Use space bar to select/unselect devices and hit Enter to continue once the proper device is selected. If you're not sure which device to choose, simply ask here and post a screenshot of the prompt and I will help you chose.

Once you've done this, not only will grub's boot sector be installed to the MBR of your internal drive (so that you see the grub menu even when the USB drive isn't plugged in) but the grub-pc package will also be properly configured to continue installing grub's boot sector there whenever it's upgraded.

  • thanks @Jordan Uggla. I have tried the above steps, and gladly, I'm now able to boot it up from the hard drive. Excellent. thanks very much!
    – kip2
    Aug 30 '12 at 17:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.