On HP 3115m (business version of dm1z) with 64-bit Ubuntu 12.04 there is a problem with the driver support for the ralink 3592 wireless chipset.

When using rt2800pci driver, the connection intermittently disconnects and fails to reconnect until one toggles the wireless via the hardware key (f12) off and then back on. After that it will connect but only for a little while before once again dropping the connection. Connection to some routers is more prone to disconnection than others. I tried changing channels, encryption protocol (wpa//wpa2), even a/b/g/n with no consistent results.

For this reason, I tried installing the official Ralink drivers (rt3562sta) that can be downloaded from http://www.ralinktech.com/en/04_support/support.php?sn=501 (namely RT3062PCI/mPCI/CB/PCIe(RT3060/RT3062/RT3562/RT3592) driver). I followed instructions (similar to the ones found here: http://ubuntuforums.org/showthread.php?t=1850267) and installed the driver while blacklisting other drivers. Now here's the curious thing. If I modprobe the driver ("sudo modprobe rt3562sta", this is btw the name of the driver created by compiling), assuming that there are no other drivers loaded, I get nothing (e.g. "iwconfig" and "ifconfig" list no wireless devices).

However, if I type "sudo ifconfig ra0 up" the device does come up in "iwconfig" and "ifconfig", the LED on the keyboard turns on, and I can even scan for wireless networks via "iwlist scan" but the network-manager does not recognize existence of wireless. I also tried restarting network-manager and rebooting the machine and that had no effect.

Could this be because the wireless device is using ra0 as opposed to wlan0 (as was the case with the old wireless card) or is there something else causing problems? If so, how could one change this? Any suggestions regarding this would be most appreciated.


Once you have downloaded the source package from the Ralink website, follow these steps:

Open a terminal with Ctrl+Alt+T, and paste the following, line by line:

sudo apt-get install linux-headers-$(uname -r) build-essential dkms
cd Downloads
tar -xzf DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217.tgz
cd DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217
sed -i -e "s/$WPA1=n/$WPA1=y/g" -e "s/$WPA2=n/$WPA2=y/g" os/linux/config.mk
sudo make && sudo make install && sudo make clean
cd ..

Blacklist the built-in driver, and load the new one with:

echo "blacklist rt2800pci" | sudo tee /etc/modprobe.d/blacklist-rt2800pci.conf
sudo modprobe -rfv rt2800pci
sudo modprobe -v rt3562sta

| improve this answer | |
  • Thanks for the reply, this is exactly what I did. The only exception was me being silly and changing inside config.mk HAS_WPA_SUPPLICANT=7 instead of HAS_WPA_SUPPLICANT=y (must've been a typo...). Once again, many thanks for your help! – FlabbergastedPickle Aug 30 '12 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.