I am trying to print to a samba printer via CUPS. I have configured the printer allright, but there seems to be a problem with authentication. The error message I get is

Session setup failed: NT_STATUS_LOGON_FAILURE

The GUI also tells me: Idle - Tree connect failed (NT_STATUS_ACCESS_DENIED)

It used to work with previous versions of CUPS (1.4.3 and 1.4.6) under Ubuntu 11.04

I am doing this on a clean install of Ubuntu 12.04, CUPS version 1.5.3. I have tried changing some rights relating to apparmor, with no success as described here: http://www.compdigitec.com/labs/2010/01/16/fixing-usrlibcupsbackendsmb-failed-error-in-ubuntu/

I have been working with Ubuntu for years - but this is the kind of problem I need help with.

  • I also tried downgrading to CUPS 4.1.8, that did not help, I could not connect to localhost:631 any more. I am now back at the issue described above, any help will be greatly appreciated. – Julius Aug 29 '12 at 20:22

Hurrah, its working. The problem is related to a really strange authentication issue that 12.04 has with samba. As I also had problems connecting to the samba drives, I read that server and domain names need to be in uppercase (I have no clue why) to make them work.

For the samba printer, it was enough to just have the domain name uppercase, such as this:


take care to unlock caps lock before entering the password :-)

I hope this saves someone time.

  • Could you elaborate more on the "really strange authentication issue"? – Aaron Aug 30 '12 at 15:34
  • In my case the domain name points to a netbios print server and as: 1) netbios names are (almost) always uppercase and 2) we (in UNIX/Linux) assume case sensitively then it should be in UPPERCASE. – user242817 Feb 2 '14 at 15:38

Solution for Ubuntu 14.04.

  1. Go to Terminal and run:

     sudo nano /etc/samba/smb.conf
  2. There change:

    workgroup = YOURDOMAIN
  3. Test syntax is ok by typing in terminal:

  4. On system settings -> printer -> properties, set the authentication details as follows:

    Username youruser@domain.com
    Password yourpass
  5. Print test page

That should do it

  • This seems to do the trick also on Ubuntu 16.04. – geekoverdose Sep 14 '16 at 15:59
  • For Fedora29 I did not see "authentication details" – kokbira Apr 26 at 14:17

I had the same problem, although on a debian machine where the Windows host is connected to the domain but the Debian client is not. The solution that worked for me was as follows:

  1. Change the domain setting as suggested by Miguel above.
  2. Test for access to the printer using this command:

    /usr/bin/smbclient -L {Server_IP} -U {ad.domain.name.com}/{domain_username}

  3. Fire up the add printers dialog in Gnome, select Windows Printer via Samba

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.