Observed behavior

When opening a KDE session, a blue round icon with a human silhouette appears in tray. It offers "enable screensaver" "speak text" "speak keyboard".

It seems related to processes /usr/lib/kde4/libexec/kaccessibleapp and kaccess.

I don't really care. So far so good.


I've hit a bug and reported it to KDE. Maintainer says :

The backtrace also indicates, that you may be use Qt with accessibility enabled. If this is the case, please ask in the forums of your distribution how to disable Qt accessibility, and report back, if this fixes the issue.

Wished behavior

I wish "Qt accessibility off". That may mean not having this applet running.

Solutions already tried

  1. Looking in KDE preference panel. There is an accessibility group (visual bell, modifier keys, keyboard filter), seems unrelated to "qt accessibility", does not mention the applet.
  2. Googled, find various "solutions" for older KDE, none worked.
  3. Searched AskUbuntu. Some questions on similar topics, not this one.
  4. Tried brute force. If I kill processes containing the string "kaccess", (e.g. killall -v kaccessibleapp kaccess kglobalaccess ) it restarts right away.
  5. Tried purging "kaccessible" package.

Even after all this, qt accessibility features are still enabled, according to valgrind log.


How can I just disable qt accessibility features ? I don't need them at all and they may be the cause of the first problem.

Thank you for helping the community.

  • Any luck on this?
    – jasonwert
    Oct 16 '12 at 22:55
  • 1
    Thanks for asking. Yes, removing a package seemed to fix. I'll offer an answer, please rate. Nov 14 '12 at 9:43

The package maintainer at KDE level provided a hint.

If everything fails, check which package installs /usr/lib/x86_64-linux-gnu/qt4/plugins/accessiblebridge/libqspiaccessiblebridge.so and try to remove it. If you cannot, because of dependencies, you can manually move the file away as root, and restart the desktop. This should remove support for Qt accessibility.

On Ubuntu 12.04 that boils down to sudo dpkg --purge qt-at-spi which effectively disables Qt accessibility.

This is a bit brute force (for example, it does not allow to enable accessibility for some users only), but it does answer the question with an effective solution, right ?

  • Did not work (apparently qt-at-spi is not the package) , I had to apply @Mattmon's hack.
    – razor
    Jan 30 '13 at 2:21
  • It was tested on 12.04 amd64. The package still exists in 12.10. What distribution do you use ? What do you mean by "did not work" ? No such package, or removal ok but problem remains ? Jan 30 '13 at 6:56

I found an answer. Make kaccessibleapp not-executable. That will prevent it from starting back up.

sudo chmod a-x /usr/lib/kde4/libexec/kaccessibleapp
  • Interesting: this is a hack (and will probably cause some errors in .xsession-errors log). But if you need to keep accessibility enabled for some users, you can create a group and make the file executable only for that group. Jan 9 '13 at 19:56

The file /usr/lib/kde4/libexec/kaccessibleapp is owned by the package kaccessible, so the cleanest way to fix the problem is:

sudo apt-get purge kaccessible

remove kaccessibe package

sudo apt-get remove kaccessible
  • Thanks but what's the benefit over @happyskeptic's answer ? May 17 '15 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.