When I use gksudo nautilus to browse folders that are owned by root, my Ubuntu desktop returns to some kind of default setting - changing my wallpaper and displaying desktop icons (which I don't usually display). However, without manually changing the settings, I cannot find a way to make the settings return to my own preferences after closing the root file browser.

Is there any way to do this? I tried quitting then restarting Nautilus from the terminal but that doesn't work.

Note: I am using Ubuntu 10.04.

Edit: At Scaine's request, here is the output of gksudo nautilus:

(gksudo:20400): Gtk-WARNING **: Theme directory scalable/places/mimetypes of theme Se-interface-green has no size field

(gksudo:20400): Gtk-WARNING **: Theme directory scalable/devices/scalable/emblems of theme Se-interface-green has no size field

Initializing nautilus-gdu extension
Initializing nautilus-dropbox 0.6.7
  • Sounds like a bug. Can you try running sudo nautilus from a terminal and posting any output you see there? – Scaine Dec 19 '10 at 22:15
  • not that it should make a difference, but try not using gksudo, and use gksu instead. – RolandiXor Dec 19 '10 at 22:30
  • Err, gksudo is a symbolic link to gksu. – htorque Dec 19 '10 at 23:22

It sounds to me like somehow nautilus is running as root and replacing yourdesktop. Normally this should not happen.

However, here is a likely solution. Use:

gksu nautilus --no-desktop

when launching nautilus as root.

If you get the problem of your desktop being altered as before, run:

gksu killall nautilus

or from a terminal:

sudo killall nautilus


  • Tried the killall command from terminal and it didn't do anything. When I tried the no-desktop command, I get an error "Could find /home/username/no-desktop" – Saladin Akara Dec 19 '10 at 22:24
  • try it again, I had an error in my answer. – RolandiXor Dec 19 '10 at 22:29
  • No change with the killall commands again. And when trying --no-desktop it outputs an error: "gksu: unrecognised option '--no-desktop'" – Saladin Akara Dec 19 '10 at 22:32
  • this should be the proper solution. the "problem" is nautilus's default nature of displaying the launching user's desktop. disable it by using the --no-desktop parameter when you first use gksudo nautilus --no-desktop – Joshua K Dec 20 '10 at 4:28
  • are you running gksu --no-desktop? instead of gksu *nautilus* --no-desktop? You run --no-desktop alone... – RolandiXor Dec 20 '10 at 12:58

This should never happen however

To resolve you can restart nautilus

Open the Terminal (Ctrl-Alt-T) and type

nautilus -q 

Then hit enter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.