So, today, I decided to turn off bluetooth to save battery power. When I did so, it did everything like normal. Whatever. But whenever I want to re-enable Wifi and Bluetooth, it just has "Enable Wireless" and "Enable bluetooth" grayed out in the respective things on the top-right of the desktop. I am using 12.04 Precise Pangolin on a Dell laptop that has never had wireless problems before. Clicking the grayed-out part does nothing. Re-logging and restarting has no effect, and I'm on an account that has full administrative permission.

My attempts:

~$ sudo dmesg | grep wlan0
[19.960211] ADDRCONF(NETDEV_UP): wlan0: link is not ready


~$ sudo dmesg | grep blue


What do I do to manually re-enable wireless and bluetooth?


I found that under my "Bluetooth settings", I couldn't click anything and it said it was disabled by hardware switch.

So, I looked at my keyboard, and there's kind of this radio tower over "F2" in the color of the FN button. So I pressed FN-F2 and it re-enabled wireless and bluetooth.

I don't even remember pressing that button ever before, but I pressed it, and it worked.

Future viewers: If you see that your wireless AND bluetooth are disabled, and you're on a laptop, press FN-(wireless button, for example mine was F2). This will likely solve your problems.

What a simple solution. Really surprised this solution hasn't come up in any other Ask pages I've seen so far.

If this doesn't work, try the console commands:

sudo service wireless start
sudo service bluetooth start

as those returned neutral or favorable results for me, regardless of the button being down or not.

  • Nice man, glad to see that your issue was solved! And have to note that I had faced issues like that in the past successfully. It is surprising that it didn't strike me this time. – NlightNFotis Aug 27 '12 at 21:04
  • Yeah, I know, it is such an obvious answer to such a simple question. We really overthought it. I did look it up though. Apparently, in Ubuntu 12.04 (and this is apparently not very common, I saw maybe 1 or 2 forum posts about it), turning off bluetooth switches the hardware switch for the wireless button, because I NEVER pressed that button. It may be my computer model or something. But all I clicked was bluetooth and bam. Whatever. Problem solved. Hope I help someone else quicker than I helped myself xD – tacozmeister Aug 27 '12 at 21:10
  • Mark your answer as accepted so people can see the solution if they face the same problem. – NlightNFotis Aug 27 '12 at 21:17

I installed Ubuntu 12.04.1 LTS few days ago (I was using Mint 10 earlier) and I have identical problem.

The icon says bluetooth is on, but there aren't any options and in bluetooth settings it says it's disabled.

I found the solution working for me:

sudo service bluetooth restart

I simply restarted the service, and it started working immediately!

My laptop is Samsung NP300E5A, Intel Centrino Wireless-N 130 (WiFi & BT).


Try this:

For networking:

sudo /etc/init.d/networking start

For the bluetooth:

sudo /etc/init.d/bluetooth start

If the above do not work, you have to check if the kernel recognises the modules properly (which I assume it does, since you have used it before) by using:

dmesg | grep blue


dmesg | grep wlan0
  • for networking, it returned "Rather than invoking init scripts through . . . . " and gave me a suggestion of a command to do instead. I did that, and it said "rejected send message, 1 matched rules;" and a bunch more AKA, doesn't work – tacozmeister Aug 27 '12 at 20:18
  • Okay. So, "sudo service wireless start" returned "networking stop/waiting". I dunno what that means. And "dmesh | grep wlan0" returned "[ 19.960211] ADDRCONF(NETDEV_UP): wlan0: link is not ready" bold was in red Bluetooth is allegedly working on the console. 'sudo service bluetooth start start: job is already running: bluetooth' – tacozmeister Aug 27 '12 at 20:22
  • Are you able to use wireless connectivity now? – NlightNFotis Aug 27 '12 at 20:28
  • No. Bluetooth is still disabled, too. According to the thingie in the top-right – tacozmeister Aug 27 '12 at 20:29
  • 1
    Can u type dmesg | grep wlan and dmesg | grep bluetooth and paste the output in your question? – NlightNFotis Aug 27 '12 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.