Possible Duplicate:
Ubuntu does not put Fedora into GRUB menu

After a software update for Ubuntu, my dual boot with Fedora will not show Fedora in the start menu. It just boots into Ubuntu and when I hold Shift and boot, it only has Ubuntu in the list.

I have tried the post about installing grub-customizer but when I run that, I get

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package grub-customizer

I cannot find any other way to fix this problem. I am a complete newbie to Linux.

  • What version of Ubuntu? Note that we cannot help if the problem is Fedora-related, but IMHO this looks on-topic. – nanofarad Aug 26 '12 at 19:38
  • it is the 12.04 version. fedora was 17 and both are fresh installs. i installed Ubuntu first then Fedora. Fedora asked to shrink Ubuntu and after all install both showed on boot menu. then i booted into Ubuntu and done the updates and when it rebooted thats when Fedora was missing from the boot menu. – andrew Aug 27 '12 at 6:43
  • OK. We can probably help with that here. – nanofarad Aug 27 '12 at 11:39

After mounting the Fedora partition in Ubuntu, you can see the menu.lst file of Fedora which will be located in /boot/. Convert the entry which says title Fedora to a GRUB 2 entry and include it in /boot/grub/grub.cfg in the Ubuntu filesystem. Save and restart. You will get back your Fedora.

Note: you have to edit this file as super user, i.e. with

sudo gedit /boot/grub/grub.cfg
| improve this answer | |
  • One should not use sudo with a graphical program due to possibilities of extraneous Xauthority files. Always use gksudo with a graphical program. – nanofarad Sep 14 '12 at 7:50
  • shouldn't a sudo update-grub from Ubuntu pick it up and make this addition automatically? I guess it does. Do give it a try. – Mahesh Sep 23 '12 at 19:03
  • It doesn't. I gave it a try. – chazdg Sep 29 '13 at 20:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.