6

I'm trying to use the built-in bluetooth device of my Lenovo Thinkpad E320. It seems to be hard blocked, but i can't find any possibility to unblock it.

rfkill list returns:

0: tpacpi_bluetooth_sw: Bluetooth   
Soft blocked: yes   
Hard blocked:yes

cat /proc/acpi/ibm/bluetooth returns:

status:     disabled
commands:   enable, disable

I tried to enable it by:

  • Pressing Fn+F9 (Radio controll)
  • echo enable | tee /proc/acpi/ibm/bluetooth
  • rfkill unblock bluetooth
  • Trough the BIOS. But it's not mentioned at all

None of the actions influenced the ouputs above.

4
  • 1
    I believe you've left off the quotes around enable in echo enable | tee /proc/acpi/ibm/bluetooth. It should be echo 'enable' | sudo tee /proc/acpi/ibm/bluetooth IIRC,
    – nanofarad
    Aug 26, 2012 at 19:55
  • Still no success... (with quotes)
    – Non
    Aug 26, 2012 at 20:31
  • 3
    Some people activated bluetooth in a dual booted windows. After a reboot it worked in linux too.
    – Non
    Aug 26, 2012 at 20:42
  • I have the same issues and can temporarily get it working disabling the bios settings related to Bluetooth, restarting and then re-enabling them again. However unfortunately this reverts back as soon as I suspend the laptop and then I have to repeat the whole process over again. Not really what I'd expect from an Ubuntu certified laptop. :-/
    – Gerry
    Jan 3, 2014 at 15:28

4 Answers 4

4

after 5-10 bios resets to re-enable bluetooth during the last two years I decided to investigate this issue again. looks like there is a bluetooth switch emulation in the thinkpad_acpi module. turn this on via module options et voila -> working bluetooth!

echo options thinkpad_acpi dbg_bluetoothemul=1 bluetooth_state=1 | sudo tee -a /etc/modprobe.d/thinkpad_acpi.conf

reboot && block/unblock bluetooth as needed:

rfkill unblock all
1
  • Depending on the laptop version, it may be necessary to instead set the WLSW emulation option instead, using dbg_wlswemul=1 wlsw_state=1. This forces a master-level wireless switch to be emulated as always being on, which could otherwise disable all wireless use in thinkpad_acpi driver. Thank you very much for this answer, as it was the final piece that led me to a working solution. Jun 6, 2021 at 21:39
1

I was also facing the same problem before. I had the parallel installation of Windows. For working of blue-tooth, if I needed to start the blue-tooth option, I enable it with F9 function key of Windows. Then it starts working in Linux. If you have Windows installation there just check this case.

0

I resolved it by resetting BIOS settings. Be careful if you use EFI boot - it will erased and you will need to recover it.

0

Press Fn plus various keys on the first row from F1 to Delete. In my case, Fn+Insert worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.