12

Laptop-mode is said to be one of the energy efficiency boosters for Linux. Now, sources I found say that to activate it you need to:

  1. Install laptop-mode-tools.
  2. Append LAPTOP_MODE_ENABLED=true (if it doesn't exist; otherwise make sure that it's set to true) inside /etc/default/acpi-support.

However, even after doing this, laptop mode is not running (I have it set up in /etc/laptop-mode/laptop-mode.conf to be always on):

~$ cat /proc/sys/vm/laptop_mode 
0

Does anyone know how can I enable laptop-mode?

It is mentioned here that the Ubuntu package is "crippled". Is it really the case that Ubuntu doesn't allow you to enter this mode on AC? If so, why?

Edit: It seems that laptop-mode is not necessary any more since Ubuntu 12.04, according to Is "laptop-mode-tools" still relevant for 12.04 and the 3.x kernels?

3
  • 1
    I have laptop mode enabled on my system though
    – Mysterio
    Aug 26 '12 at 17:34
  • Laptop mode magically started working without me changing anything, so I guess the above steps are sufficient. I must have not rebooted enough times (or I maybe just did a log off - log on and that isn't enough).
    – metakermit
    Aug 27 '12 at 19:19
  • See also: askubuntu.com/questions/172391/… Aug 29 '12 at 16:06
12

The steps listed in the question are correct, the only thing remaining is to reboot your machine (possibly a couple of times). After that laptop mode will be enabled:

~$ cat /proc/sys/vm/laptop_mode 
2

Once laptop-mode is working, you can follow these steps to configure laptop-mode...

Edit /etc/laptop-mode/laptop-mode.conf and change

ENABLE_LAPTOP_MODE_ON_AC=0

to

ENABLE_LAPTOP_MODE_ON_AC=1

Also check for the battery mode on battery state and turn it on if it is off by changing the value to 1

e.g.: ENABLE_LAPTOP_MODE_ON_BATTERY = 1

You can set many other option in this config file (the file has many self-explanatory comments). You should try setting them to your liking.

When you're done, restart laptop-mode with:

sudo /etc/init.d/laptop-mode restart

P.S. If laptop-mode is still not on after rebooting the machine, you can try playing with this command as well to manually enable it:

Check that it's active on AC with for example:

$ sudo laptop_mode start

which should output:

Laptop mode 
enabled, 
active [unchanged]

Hope this helps..

4
  • Thanks for the tips about configuring laptop-mode. I also picked those settings in laptop-mode.conf. Just take care to have the LAPTOP_MODE_ENABLED=true inside /etc/deffault/acpi-support so that you don't have to turn it on manually every time - it seems this does work in the end.
    – metakermit
    Aug 27 '12 at 19:22
  • please what line is this setting on inside the acpi-support file?
    – Mysterio
    Aug 28 '12 at 5:58
  • 1
    I appended it to the end of the file, because it didn't exist in my acpi-support file. Take a look at the original question, I edited it to be more clear.
    – metakermit
    Aug 29 '12 at 14:29
  • Why did you change powersave mode on in AC by ENABLE_LAPTOP_MODE_ON_AC=1? I am thinking it here unix.stackexchange.com/q/307646/16920 where I need power in computations, especially when I am in AC. Sep 3 '16 at 11:48
3

enter root by

sudo su

and then

echo 5 > /proc/sys/vm/laptop_mode

If you want more tips to save power check out LessWatts. I was able to extend my battery life from 2 hours to 3 and a half.

4
  • Thanks for the tip, though I think echoing to /proc is a temporary solution - one would have to repeat it after every system boot. See my comment to the original question, I got the acpi config file method working after all.
    – metakermit
    Aug 27 '12 at 19:26
  • nope. when you do it as root, it sets it permanently. Aug 27 '12 at 20:56
  • OK, well then this is another method of doing it.
    – metakermit
    Aug 29 '12 at 14:19
  • Add line like vm.laptop_mode=5 under /etc/sysctl.d to have it applied every boot. Jun 22 '18 at 5:30
0

In Lubuntu Menu choose Preferences -> Default applications for LXSession -> Settings -> Laptop mode -> yes

2
  • What does this actually do?
    – Michael
    Jul 4 '18 at 6:06
  • I don't know. With a quick search I got the impression that it might be related to TLP or Laptop mode tools: "14. Tweaks For Ubuntu Power Management ... Apart from these tips, you can follow to install TLP, which helps to keep the laptop cool and safe. ... You can also Install Laptop Mode Tools, which helps to reduce power consumption by slowing down Hard disk speed and kernel control. To install it run the following command… sudo ..."
    – loop
    Jul 4 '18 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.