I recently upgraded my aging 802.11b wireless card to a WMP600N. I bought this as I had read that it worked with Linux.

It did indeed work out of the box but the problem is that it stops working after a few minutes. No more traffic flows over the network. Just trying to ping my router results in a Destination Host Unreachable message.

The syslog shows no indication that there has been any problem. The only way to address this is to reconnect to the wireless network using the network dropdown beside the clock. This high frequency of disconnection makes the system effectively unusable.

I have a dual-boot Ubuntu/Windows 7 system and the network connection is stable in Windows indicating that it is not an inherent problem with the hardware.

Diagnostic information

Here is some diagnostic information.

The output in the syslog when I reconnect to the wireless network is quite verbose so I have pasted it elsewhere. I didn't spot anything that hinted at the cause of the problem:

/var/log/kern.log contents (although this looks like it already exists in the syslog output above):

Output from dmesg:

Output from iwconfig:

lo        no wireless extensions.

wlan1     IEEE 802.11abgn  ESSID:"BTHomeHub2-Z924"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:24:17:64:B0:E1   
          Bit Rate=52 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=44/70  Signal level=-66 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1020  Invalid misc:69   Missed beacon:0

eth0      no wireless extensions.

Output from ifconfig wlan1:

wlan1     Link encap:Ethernet  HWaddr 98:fc:11:e3:8a:51  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::9afc:11ff:fee3:8a51/64 Scope:Link
          RX packets:6729 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6399 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5345413 (5.3 MB)  TX bytes:977231 (977.2 KB)

Output from lshw -C network:

      description: Ethernet interface
      product: AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
      vendor: Atheros Communications Inc.
      physical id: 0
      bus info: pci@0000:02:00.0
      logical name: eth0
      version: b0
      serial: 00:24:8c:29:a1:de
      capacity: 1Gbit/s
      width: 64 bits
      clock: 33MHz
      capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
      configuration: autonegotiation=on broadcast=yes driver=ATL1E driverversion= firmware=L1e latency=0 link=no multicast=yes port=twisted pair
      resources: irq:46 memory:fe8c0000-fe8fffff ioport:cc00(size=128)
      description: Wireless interface
      product: RT2800 802.11n PCI
      vendor: Ralink corp.
      physical id: 1
      bus info: pci@0000:06:01.0
      logical name: wlan1
      version: 00
      serial: 98:fc:11:e3:8a:51
      width: 32 bits
      clock: 33MHz
      capabilities: pm bus_master cap_list ethernet physical wireless
      configuration: broadcast=yes driver=rt2800pci driverversion=3.2.0-29-generic firmware=0.34 ip= latency=64 link=yes maxlatency=4 mingnt=2 multicast=yes wireless=IEEE 802.11abgn
      resources: irq:17 memory:febf0000-febfffff

From what I can find out, the card uses a Ralink RT2860 chip but Ubuntu is using an rt2800 driver:

burhan@ubuntu:~$ lsmod | grep rt2800
rt2800pci              18715  0
rt2800lib              58925  1 rt2800pci
crc_ccitt              12667  1 rt2800lib
rt2x00pci              14577  1 rt2800pci
rt2x00lib              51144  3 rt2800pci,rt2800lib,rt2x00pci
mac80211              506816  3 rt2800lib,rt2x00pci,rt2x00lib
eeprom_93cx6           12725  1 rt2800pci

Things I have tried

I have downloaded the RT2860 Linux drivers from the Ralink website but they are dated July 2010 and their instructions are non-trivial so I haven't attempted to use them yet.

Related questions

  • Please share the content or output of the following commands/files to better help us troubleshoot your problem (instructions in this answer): file(s): /var/log/kern.log, command(s): dmesg – ish Aug 26 '12 at 17:09
  • @izx Done. Although both sets of output look like they are a subset of what was in the syslog output I already posted. As an side, pastebinit is awesome. – Burhan Ali Aug 26 '12 at 22:29
  • Burhan, did you try with the latest compat-wireless drivers as indicated in my answer? – ish Aug 26 '12 at 22:43

The "official" RT2860 drivers haven't been updated since 2010 as you noted, and will not build on kernels 3.0 and newer. Your best bet is to try a newer in-kernel driver.

To build and install the driver:

We will download a recent compat-wireless-pc driver package, install build dependencies, select the RT2x00 module rt2x00, build and install it.

Type/paste the following, line-by-line, in a terminal:

sudo apt-get install build-essential linux-headers-generic linux-headers-`uname -r`
wget -O- http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2012-07-03-pc.tar.bz2 | tar -xj
cd compat-wireless-2012-07-03-pc
./scripts/driver-select rt2x00
sudo make install

You should then reboot, and then see if the wireless works any better.

  • Looking good so far. 100+MB of updates downloaded fine whereas previously it was stalling every few MB. I'll see how it goes for a bit longer and then accept this. One question though: Will I need to redo this every time I upgrade the kernel? – Burhan Ali Aug 26 '12 at 22:48
  • @BurhanAli: you can try to install the linux-backports-modules-cw-3.3-precise-generic (or generic-pae) package and see if it works (it has an older version of the compat-wireless drivers). But yes, otherwise you should just leave that folder sitting around somewhere, and simply run make && sudo make install when your kernel is upgraded – ish Aug 27 '12 at 8:48
  • More than a day now without a disconnection so that's good enough for me. Thanks! – Burhan Ali Aug 28 '12 at 23:36

There are several reasons for that, possible causes:

  1. your disk have hardware failure, like I/O errors...

  2. You have multiple firewalls enabled, and it is better to have only one, maybe "gufw" is the best... and it needs to deny all with rules to allow out udp 53 and allow out tcp 25,53,80,110,143,993,5060

  3. Your OS is not with all modules inserted, type: lsmod > list1.txt Then create an USB installer with the "startup disk creator" using the ISO of your installation CD (a pen of 2 GB is enough) then boot from that USB PEN and choose "try Ubuntu" and type there: lsmod > list2.txt and copy this file to the same location the one above and open both in text editor and see if there is missing modules in list1.txt... To install missing modules use first modinfo "name of the module" after the description see if it needs dependencies and install those first if not, just copy the full path of the ko file and type sudo insmod "paste path/file.ko" after all modules inserted no need for reboot things should start working fine...

  • 1
    It was none of these. Upgrading the driver fixed the problem. See the accepted answer above. – Burhan Ali Oct 27 '12 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.